Fluids

Fluids

Mesh adaption with inflated boundaries

    • Mohamed_Wael_Badawy
      Subscriber

      Dear sir,

      I am simulating the motion of a droplet in a micro-channel where the droplet dynamics is highly dependent on the thin layer of fluid between the interface and the wall boundaries. 

      I am trying to use VOF mesh adaption while i am using inflated mesh near the boundaries. However, I am always facing the problem of having a layer of non-adapted mesh between the inflated layers and the adapted zone. I have tried to separate the inflated mesh zone and retry the mesh adaption but i got the same results. I would like to know if there is a method that can successfully adapt the mesh according to the VOF in the vicinity of the inflated mesh zone.

    • YasserSelima
      Subscriber
      Do the adoption by coordinates using expression. Let's say you want to adopt the cells between x=0.05 m to x=0.1m ... use this expressionnIF(AND(Position.x < 0.1[m],Position.x>0.05[m]) , 1,0)n
    • Mohamed_Wael_Badawy
      Subscriber
      Thank you so much, I tried the coordinates as you suggested but it also leaves the same non adapted gapnn
    • YasserSelima
      Subscriber
      Try it without < .. like thisnIF(Position.y >0.05[m] , 1,0)nn
    • Mohamed_Wael_Badawy
      Subscriber
      Same result. Fluent intentionally leaves a layer of 1 element thick unadapted next to the inflated layers.n
    • YasserSelima
      Subscriber
      Not sure how to solve this. nYou have no option but going back to meshing if you want to solve this soon. The Ansys experts are off in the weekendsn
    • Mohamed_Wael_Badawy
      Subscriber
      Thanks for your help. What do you mean by going back to meshing?n
    • YasserSelima
      Subscriber
      How did you create your mesh in the first place. Go there and select smaller element size for this wall. And re-meshn
    • Mohamed_Wael_Badawy
      Subscriber
      I FINALLY managed to overcome this issue, I changed the minimum orthogonality ratio in the advanced mesh adaption to zero and it worked!n
    • YasserSelima
      Subscriber
      Thanks for sharing the solution!n
Viewing 9 reply threads
  • You must be logged in to reply to this topic.