3D Design

3D Design

Mesh Control with parametric variables

    • alimjalled
      Subscriber

      Hello Everyone,

      I am performing some parametric simulation. I am creating the geometry using script variables, and I am creating also groups for the mesh control.

      In Ansys Mesh I am doing some Mesh-Control (Method , Face Meshing and Inflation for my case) using "named selection". When I change the geometry by changing the parameters and update, the mesh is regenerated taking into consideration the mesh control for the face meshing and Method, but the problem is that the Inflation doesn't work (however it appears in the Outline Tree). I should remove it and re-define it again to see it. How can I solve this issue ?

      the figures below show the mesh before and after changing a parameter in workbench. (notice that the method control of triangular mesh and the face sizing are kept, however the inflation didn't show)

    • Keyur Kanade
      Ansys Employee
    • alimjalled
      Subscriber
      I used Named Selection for inflation and I am sure also they are updated correctly but nothing they don't appear. When I remove them and re-define them with NS again they appear
    • Keyur Kanade
      Ansys Employee
      Does no. of edges or faces change?
      If yes, start with most no. of edges/faces. Then change parameter to reduce them step by step.
      Regards Keyur
      How to access Ansys Online Help Document
      How to show full resolution image
      Guidelines on the Student Community
      How to use Google to search within Ansys Student Community
    • alimjalled
      Subscriber
      My problem is that only the Inflation control doesn't appear after making a new design point. I am always making the inflation for 2 edges, their length only varies, whatever the parameters are, I will get 2 edges (wavy in shape) on which I want to apply inflation.
    • Keyur Kanade
      Ansys Employee
      Please check if NS getting updated correctly? Insert image.


Viewing 5 reply threads
  • You must be logged in to reply to this topic.