Optical

Optical

Mode expansion monitor error

    • sudharsanan srinivasan
      Subscriber

      I am trying to edit the Lumerical file for Y-branch optimization using PSO. I just replaced the splitter section with a spline bend. The field simulation seems to run fine except I am receiving an Error: "Error: prompt line 1: Can not find result 'expansion for out' in the result provider 'modeExpout'". This error seems to occur regardless of where the monitor is placed, like say in the case when it is next to the source. Please advice.

    • Guilin Sun
      Ansys Employee

      Do you mean this example https://optics.ansys.com/hc/en-us/articles/360042800353-Y-branch ?

      How did you specify "expansion for out"?  did you use port result, or have power monitor and expansion monitor? did you choose the mode to be decomposed and have the variable name to output the decomposed result?

       

      Please check every step, and make sure the sweep can pick up the decomposed result, with proper settings. If you still cannot resolve this, please give screenshots  for all related objects so we can know where is wrong.

    • sudharsanan srinivasan
      Subscriber

      This is the example I downloaded. https://optics.ansys.com/hc/en-us/articles/360042800333

      I did not change anything from the original file except the geometry. The original example runs well. Some screen shots are attached.

    • Guilin Sun
      Ansys Employee

      If you only modify the geometry, you may need to recalculate the mode in expansion monitor. Please visualize the mode profile,and make sure it is normal. In addition, please visualize the fields in monitor "out".

      Make sure the mode expansion monitor and the DFT monitor are in the same waveguide. better at the same location.

       

    • sudharsanan srinivasan
      Subscriber

      Yes, I have taken care of all your tips, no luck.

    • Guilin Sun
      Ansys Employee

      This may indicate that something has been changed. I would suggest that you download the example again, first run it to confirm everything is ok. Then modify the structure. Before running, reselect the modes and make sure they have updated. Other than the above suggestion, the forum may not be able to help further. If you have premium support, please send us email with simulation file attached.

Viewing 5 reply threads
  • You must be logged in to reply to this topic.