Preprocessing

Preprocessing

Need help in fixing drop in mesh quality due to creation of stairstep mesh after adding inflation

    • Doba
      Subscriber


       


      After adding inflation I'm getting this error - "Inflation created stairstep mesh at some locations." and the mesh quality is decreasing.


      What can I do here to improve the mesh quality? I have tinkered with basically all inflation settings but the result more or less remains the same.


       

    • peteroznewman
      Subscriber

      I recommend you go back to the geometry editor and add a blend radius to every point of every triangle. That will allow the inflation to smoothly work its way around each triangle "vertex" because there will be a tangent curve to wrap around.

    • Doba
      Subscriber

      You mean every edge? As the flow is facing the triangular top of the prisms, I am thinking of adding blend radius only to edges along that, not the perpendicular edges as their sharpness isn't affecting the inflation (I hope that was understandable)

    • Rob
      Ansys Employee

      If you're meshing inside the beam structure too reduce the minimum cell size: part of your problem is how the inflation is interacting with the background cell size. 

    • peteroznewman
      Subscriber

      In a 2D view, each triangle has a vertex or point at the corner.  In 3D extrusion of that 2D view, that vertex becomes an edge. Yes, I mean every edge at the vertex.


      rwoolhou makes a good point to use smaller elements on the faces that are not triangles. You could pick all the sides of the triangle and bias the nodes to each vertex. That would also help.

    • Doba
      Subscriber

      If you're meshing inside the beam structure too reduce the minimum cell size: part of your problem is how the inflation is interacting with the background cell size. 



      You mean the "Element size" or "Curvature/Proximity min size"?

    • Rob
      Ansys Employee

      Yes, either, both.  Have a look at the sizes compared with your model and alter to suit. 


       

    • Doba
      Subscriber

      So I have tried adding blend radius and reduce the minimum cell size (along with some other settings like growth rate and defeature size) but I still can't get it right.




      From the 2nd image you can see that the worst elements are near the bottom and top of the prism. This is where the inflation layers are starting to form. I noticed that the section where all layers have been "set", there are hardly any bad elements.


      Do you guys have any other tips?

    • Rob
      Ansys Employee

      Try one layer only, and further increase the resolution on the solid faces/volume. 

    • peteroznewman
      Subscriber

      Since the worst elements are where the inflation layers start and end, try slicing the fluid volume at those two planes (and form a multibody part to use shared topology) then mesh that body first (selective body meshing). If you slice the volume that way, does that make that body sweepable? If so, you would have a face to mesh and then sweep along with mostly hex elements.

Viewing 9 reply threads
  • You must be logged in to reply to this topic.