Ansys Products

Ansys Products

Not enough HPC Parallel licenses 20/0.

    • apr37
      Subscriber
      Hello,nI have a few Windows 10 machines with Ansys EDT, RSM and Intel MPI installed, configured together in a HPC setup for doing distributed solves. I am able to execute and complete analysis of the simulation, but when I start a solve, my Message Manager always opens with the following:n [error] Not enough HPC Parallel licenses 20/0. (10:31:59 AM Mar 23, 2021)n [error] Simulation was terminated by license error. (10:31:59 AM Mar 23, 2021)n [error] Not enough HPC Parallel licenses 20/0. (10:32:02 AM Mar 23, 2021)n [error] Simulation was terminated by license error. (10:32:02 AM Mar 23, 2021)n [error] Not enough HPC Parallel licenses 20/0. (10:32:04 AM Mar 23, 2021)n [error] Simulation was terminated by license error. (10:32:04 AM Mar 23, 2021)n [info] Parametric Analysis on 1_test_sweep_centered has been started. (10:32:05 AM Mar 23, 2021)n [info] A variation (sample_position='0.001mm') has been requested using the following machines: localhost. (10:32:07 AM Mar 23, 2021)nIt seems to be repeating itself once per remote machine I have set up as a compute node before a request is made by localhost like normal. Performance doesn't seem to be affected (remote compute nodes still request and solve variations), and this happens even when I have firewalls turned off on all machines.nWhat does this mean? What could be causing this to happen? How should I go about fixing it?nThank you,nAlexn
    • ANSYS_MMadore
      Ansys Employee
      Can you share what you have set for your HPC and Analysis Options tabs and analysis configuration setting?n
    • apr37
      Subscriber
      Here is my HPC and Analysis OptionsnIs this what you are looking for?.
    • ANSYS_MMadore
      Ansys Employee
      ArrayPlease change Use legacy Electronics HPC License to True.n
    • apr37
      Subscriber
      Should I change that setting on the head node and compute nodes, or just the head node only?.When I change it on all nodes (testing with only two computers for now), Progress hangs on Determing memory availability on distributed machines on Local Machine.nAnd I need to abort the process.nnWhen I change it on only the head node, I get an execution error in message manager:n   [error] Could not start the memory inquiry solver:check distributed installations, MPI availability, MPI authentication and firewall settings. (8:16:24 AM Mar 26, 2021)n   [error] Simulation completed with execution error on server:Local Machine. (8:16:44 AM Mar 26, 2021)nnI have made no changes to the firewall since I last successfully distributed a solve with the old license settings shown the earlier screenshot.
    • AndyJP
      Subscriber
      model checkup is done without checking a license. there are many license types, so you should inquire the distributor about which you have, or try every option mentioned above.nbut sometimes the license server just does not work or freeze licenses. it is a big problem existing from the beginning of flexlm. it is simply not reliable in big networks.nso check the debug logs at the server, and see, did your client really tried borrowing a license? if yes, what was the real reason of failure? if not, check IP packets passing, firewalls, router etc.n
    • apr37
      Subscriber
      Thanks for the information, AndyJP.nI'm fairly naive to the inner workings of the system, but I am eager to learn and get a better grasp of how to diagnose and fix problems like this and generally understand the system better. I have a few questions for you:nWhat is model checkup?nCould you point me to more information on license types?nWho would be my distributor? If I am a student, would it be my university?nCould you point me to more information on how to check debug logs at the server?nIs it the expected behavior that the client borrow the license? Who is the client borrowing the license from? The server? Are the client and server in this case the same thing as head node and compute node? (Borrowing terminology from the HPC help document)nAnd last, interesting to hear that this has been a problem for a long time. In your experience is it detrimental to have this problem? What limitations does it place on you or me? It seems I am able to run my simulations even with this licensing error, I'm just trying to do what strikes me as good practice and chase down the cause of error message I run into.nThanks again,nAlexn
    • ANSYS_MMadore
      Ansys Employee
      Array The messages have nothing to do with licensing.nIf you are submitting the job interactively from the local AEDT, with the project open and specifying the hosts under HPC and Analysis Options -> Configurations, you only need to set it on the machine submitting the job. If you are using the Submit Job UI you would want to set it in the Batch Options.nBased on your previous post have you tried disabling the firewall to see if that will allow the job to run? If that works, you will need to open the firewall further as per the previous post. Typically the errors you are seeing are related to the MPI processes failing to communicate due to a firewall.nThe reason the job previously ran is because the Parametric Analysis isn't running with MPI though it does distribute.nn
Viewing 7 reply threads
  • You must be logged in to reply to this topic.