Ansys Products

Ansys Products

Discuss installation & licensing of our Ansys Teaching and Research products

Optislang and ZEMAX OpticStudio – error in finding .zmo and .zmi files

    • amit.pandey

      Hello All,


      i am trying to run a parametric analysis in Optic studio in combination with Optislang.

      I keep getting this error when ever I try to read the parameters from the ZEMAX file:



      The error basically cannot find the .zmi and .zmo files for the zemax files. Although this error was not happening before, it could be because I tried to upgrade to the latest versions of both the softwares. 


      Has someone also experienced something like this? I also get “uninitialized” warnings and “not correct data type” warnings which I see sporadically and not always.


      Any inputs are appreciated.


      I am running the parametric analysis with tilts, decenters, and lens dimensions as parameters to arrive at Zernike polynomials that i measure compared to the Zernike parameters that I simulate in the model. Is there a way I could do it using the merit function editor?

      I set up the Zernike polynomial operands with the wavelength and other settings. Use the values of the different Zernike coefficients that I want to reach as “targets” in the editor but when running the optimization, I am nowhere close to where I want to be and hence my choice of running it with optislang for a larger parametric analysis run.


      With best regards,


    • amit.pandey




      After response from Zemax support, I updated the versions of both OptiSlang and Optic Studio to 2022R1 and 22.2.1 respectively.

      Created a new guided project from scratch, with ZEMAX module in OptiSlang and it works now.

      Faced issuses with:


      1. Loading an old optislang “.opf” file and re-running the Zemax node did not solve the issue even after the installing the newer versions. A new project has to be created.
      2. The .zmx model have to be saved again with all the inputs(variables in the LDE) and responses(all operands in the MFE). The old .zmx file has to be overwritten. Just save does not work for some reason.





Viewing 1 reply thread
  • You must be logged in to reply to this topic.