General Mechanical

General Mechanical

Topics relate to Mechanical Enterprise, Motion, Additive Print and more

Pipe pressure load error with shared topology

    • Moisés González Tamargo

      Hello everyone,


      I am trying to simulate an inflatable structure with pipe and shell elements, the elements are mechanically attached so as to transfer the loads between them, so I use the share topology option in my SpaceClaim geometry.

      However, when importing it to ANSYS Mechanical, I am no table to apply the internal inner pressure to the pipes, I tried to un-share the pipe structure from the outer shell envelope and attach them with bounding connections but I am getting an ill matrix error upon solution.

      I cannot upload any details about the project, but I replicated an example of the configuration with a cube, the edges are modelled as beam elements and the faces as Shell, all of them with 0.1 mm thickness. When I try to share the topology, I get the following error:

      And disabling the share topology and setting up manual bonding connections I do manage to get it working and obtain a reasonable solution:

      The pipe element sizing not matching the face sizing was done on purpose.

      Nevertheless, the automatic contacts are not working in the entire model I am having issues with and establishing hundreds of contacts manually would be my last resource.


      Any suggestions would be highly appreciated.


      Best regards.

    • Naresh Patre
      Ansys Employee


      Under Connections branch of Mechanical if you add a new Connection group and set Face/Edge and Edge/Edge option as "Yes" and generate contacts, this should automatically generate contacts between the edge and the face. Can you try out this option and see if it helps?

    • Moisés González Tamargo


      Thanks for your reply,


      I have alredy tried to generate connections in this way but Mechanical crashed every single time.

      However, I managed to get it working by using mesh connections and selecting all bodies in my geometry. Similarly to what is done in this tutorial: Batch Connections in Ansys – Never use Share Topology for Beam and Shell models | Finite Element Analysis (FEA) Blog – LEAP Australia & New Zealand


      The problem now comes when I implement this solution onto my full model. The aforementioned error disapears but I get an unknown error when solving: Invalid element number = 0. The SFE command is ignored. Which doesn´t occur when I suppress the pipe pressure load.

      ¿Is there any other way of running this simulation?


Viewing 2 reply threads
  • You must be logged in to reply to this topic.