Photonics

Photonics

Plot axis are not the same as clipped plane axis ?

    • Mariah Ha
      Subscriber

      Hi, 

      I have this axis issue when I plot the Electric field of the 3D structure . The y axis for example in the 3D figure is not the same as the y axis of the clipped plane (red plane) . The y axis of the clipped plane picture is centered in 0 and gives wrong locations of the structure layers.

    • Khashayar Ghaffari
      Ansys Employee

      Hi,

      Thank you for taking the time to report this. From what I understand the issue you have is that one of the plots (that from the solver itself) reports a range of values that doesn't match the real coordinates and those observed in the 2D monitor you added yourself.

      I tried to reproduce this but on my side, but the values match in the example I created. I am not sure whether a specific setup causes the isse you see, or if it's somehow related to the visualization (I notice the legends can be very close in the 3D plot). To confirm the data you can read the y coordinates value from the dataset. 

      To do this click on the result holder ("CHARGE" or the monitor). Send the results to script (here the result would be "electrostatics") and then read the coordinates (with a command like ?electrostatics.y;). The results from the two monitors should be the same, if not as you suggested there is a software error (which unfortunately I can not recreate on my side).

    • Mariah Ha
      Subscriber

       

      Thank you for the assistance. The issue is solved .I was clicking on "visualize 2D plane data " instead of "show clipped plane". But what is the role of the "visualize the2D plane data" if it gives the same plot but different axis ?

Viewing 2 reply threads
  • You must be logged in to reply to this topic.