3D Design

3D Design

Poor quality surface in extracted volume – Ansys SpaceClaim

    • openAC
      Subscriber

      I have a complex 3D geometry with internal flow. As I try to use volume extract in Ansys SpaceClaim 18.1 (Institute Academic License) for extracting the fluid domain, I do obtain a fluid volume. However, the volume extracted looks poor quality for some reason. The original geometry has much smoother surfaces for the same component.

      Has anyone else faced something similar? Is there a precision or a tolerance setting I need to use before volume extraction?


      See image-1 for a test surface that is on the actual solid structure. Image-2 shows the surface on the extracted volume corresponding to the above surface. The actual solid looks smooth and the extracted solid looks faceted like in image-2. Interestingly, if I take this surface from my extracted volume and either "detach" it or paste it to a fresh design window, it looks smooth again.


      Image-1


      Image-2
      I feel like there is something really basic I am missing. This is my first time using SpaceClaim. Thanks in advance and sorry for any oversight in my query.

    • Aniket
      Ansys Employee

      Most probably it is just rendering issue:


      Please go to SpaceClaim>File>SpaceClaim options and increase rendering quality then recalculate rendering.


    • openAC
      Subscriber

      Thank you for replying, Aniket.


      The rendering quality goes from 1(Lowest) to 7(Highest) on my old laptop -- Intel Pentium CPU N3520 @ 2.16GHz.


      If I select anything other than 3, the "Recalculate Rendering" Button becomes inactive.


      You maybe right about this being a rendering issue, but then why do I see a smoother geometry for the solid structure but not for the extracted volume?

    • peteroznewman
      Subscriber

      I saw the same thing in this example, but I didn't know how to extract that face off the filled volume to study it separately.


      Peter

    • openAC
      Subscriber

      @peteroznewman I also couldn't separate it from the full body by hiding the other faces. If I "Detach" by right clicking on that surface and selecting "Detach", then I can see it separately, but then the surface looks smooth like in the original solid.


      I am puzzled what may be going on.

    • FrankD
      Ansys Employee

      There is almost no need to put the rendering at 10. This was added for resolving extremely small surfaces on very large models, and has the potential to drag the performance down significantly, on even the highest end graphics cards (this is why it is colored red in the UI.)


      You will not be able to distinguish with the naked eye, any improvement over setting 7 (the highest in regular use) 


       


      Perhaps, Aniket, you could re-snap your image showing setting 7, so as not to encourage the use of 10?


      Thanks


      F

    • openAC
      Subscriber

      I did some more analysis, by taking a simple expanding nozzle like solid. See the attached figure. If I just take my nozzle solid and extract the inner volume, it looks very smooth. However, if I add a large (about 4 times the maximum diameter) outlet domain body to this test nozzle, while my solid still looks smooth, the extracted volume has very poor quality surface to capture the nozzle surface.


      Maybe there is an optimization algorithm that comes into play while extracting that has the domain size as its parameter.


      I am curious how I can address this.


      Of course, for now I think that I can simply do the volume extraction on the nozzle geometry and add the outlet domain on the extracted volume. But, my concern is that there is some tolerance or some parameter I am missing to control the tesselation.


      All these images are using Ansys Fluent Meshing Mode and the geometry is in SpaceClaim 18.1 (SCDOC format).comparison

    • Keyur Kanade
      Ansys Employee

      Hello, 


      First you may want to use latest version which is R19.1. Please check it resolves your issue. 


      If you are importing in Fluent Meshing, then there are Tolerance controls while importing. Please use tolerance of 0.01 or 0.001 while importing in Fluent Meshing. 


      Also please check by taking geometry from SpaceClaim to Workbench Meshing. You can generate surface mesh in Workbench Meshing for particular part in question and then export .msh file to take it to Fluent Meshing. I would prefer this approach for nozzle so that I can accurately capture all curvatures. 


      Regards,


      Keyur

    • openAC
      Subscriber

      Hi Keyur,


      I tried using the tolerance parameter as 0.001 while importing to Fluent Meshing. The faces on the large outlet domain look much smoother than before, and I can see the number of tessellated faces has increased, but the curve of the nozzle is still poor as though it only knows that piecewise linear geometry with 4 or 5 segments. I am increasingly sure that something is happening during volume extract that affects the extracted faces when the large outlet domain is present.


      Thank you for your tips on mixing Workbench meshing and Fluent meshing. I will think about how to do this.


      Regards.

    • openAC
      Subscriber

      Thanks for all you suggestions.


      For now, I have solved my problem. In case anyone comes across this in future, here are my notes:


      1. Extract the fluid volume only from the nozzle geometry using the standard "Volume extract" tool.


      2. Above step results in the extracted volume that has surfaces as smooth as the original solid.


      3. I add the large outlet volume on this extracted volume of the nozzle. The surface quality remains good in this case.

Viewing 9 reply threads
  • You must be logged in to reply to this topic.