Photonics

Photonics

Positioning ellipse ring in Lumerical

    • amnonjw
      Subscriber

      Hi,

      I am building a model of ellipsoid rings.

      I think there's a bug with the center position once I mark the ring element as ellipsoid: the coordinates (x,y) of the center position of the ellipse are double of the set values for x and y.

      Even when I select the element in the GUI - the cross-hair marker shows the set point of the center, but there's no ring there. Instead of (-0.5,-0.4)um, it's at (-1,-0.8)um. It occurs even if "radius" and "radius 2" are the same - as long as I set "make ellipsoid" as true.

      • My FDTD version is 2021 R2. I don't know if this happens in previous versions.
      • This doesn't happen if the ring isn't ellipsoid, and also doesn't happen for a circle element that I mark as an ellipsoid.

      I attached the model file for tests.

    • Guilin Sun
      Ansys Employee
      Thank you for raising this issue. We will investigate more about this. Have a great weekend!
    • amnonjw
      Subscriber
      Hi I now find another troubling issue: when using a ring as ellipsoid - the continuous arc becomes a polygon
      I used the same model I attached in the first post - and once I mark the "make ellipsoid" on two rings with the same dimensions - I get a polygon instead of an arc.
      This can terribly affect my simulation. I can handle an incorrect center by passing a halved value, but I a fix for the polygon-ring is more crucial.

    • Guilin Sun
      Ansys Employee
      This is the display issue:
      if you zoom in
      This is because the monitor screen has limited resolution:





    • amnonjw
      Subscriber
      OK To verify this I added an FDTD block with maximum resolution and a refractive index monitor for preview. I accept that both rings have the same "arc resolution".
      However I found something interesting about the position bug: The position of the "ellipsoid-ring" in the index preview is different than in the rendering window; it's actually equal to the set value of the position.

    • Guilin Sun
      Ansys Employee
      Thank you for letting me know this. It is under investigation. I may be related to geometry kernel for display.
    • amnonjw
      Subscriber
      Is there any progress with the rendering issue?
    • Guilin Sun
      Ansys Employee
      it is identified but has not begun to fixed it, as there are some other urgent projects ongoing. Sorry for that. Will let you know if it is fixed.
    • Guilin Sun
      Ansys Employee
      hi, The new release version just fixed this bug. Please install, test and verify. Let me know if there is any issue please.
    • amnonjw
      Subscriber
      Hi,
      I'm running IDE release 2021 R2, version 8.26.2717.
      The visualization bug is still unresolved. See attached file.
      There's also an issue with system crash when I use the object "partial ring" and mark it as an ellipsoid. I reported this as well.
    • Guilin Sun
      Ansys Employee
      According to ALF policy we are not allowed to open or download files in this Forum. Please paste the screenshots here.
    • amnonjw
      Subscriber
      The screenshots are the same as the ones that appear in the first post I made (above).
      (As an aside - accepting bug reports without accepting input files to recreate the issue seems unproductive)

    • Guilin Sun
      Ansys Employee
      WE are not allowed to download customer file in this forum.
      I tested the partial ring, and found it works when inner radius is 0:
      The version I am using is

      I am not sure the version you are using is the one that fixed this bug.


    • Guilin Sun
      Ansys Employee
      I checked the version history, and found that version 8.26.2717 was released (early July 2021) before you reported, Sept. 2021.
      Please download the latest version and test again.
    • amnonjw
      Subscriber
      Hi I get this message when I check for updates:


    • Guilin Sun
      Ansys Employee
      You can directly visit the download website:


    • amnonjw
      Subscriber
      Hi I confirm this is fixed in version 2021-R2.5
      Good job
Viewing 16 reply threads
  • You must be logged in to reply to this topic.