Ansys Products

Ansys Products

Problem with FlexNet Licensing

    • nuchizono
      Subscriber

      I just got a copy of ANSYS for our university lab and we are hosting the license on our own computer. I downloaded and installed both ANSYS 19.2 and the ANSYS License Manager Center. When I tried to add our license file to the License Manager, I ran into issues with FlexNet. I wasn't told anywhere by my ANSYS rep about needing FlexNet or what FlexNet even was.


      In the "View Status/Start/Stop License Manager" tab, it shows the following


      Licensing Interconnect: running 
      Licensing Interconnect Monitor: running 
      FlexNet Licensing: not applicable 


      In the "Add a License File" tab, it shows the following


      The selected License Management Center option is not valid for license server machines that are set up with the following license manager run modes: Run the ANSYS Licensing Interconnect without FlexNet Run the ANSYS Licensing Interconnect and FlexNet independently Please refer to the Advanced Licensing Configuration Options section of the ANSYS, Inc. Licensing Guide for additional information.


      When I try to change the run mode in the "Specify License Manager Run Mode" tab, I get the screen shown in the picture. Do I need to get FlexNet? Where do I get that? Thanks a ton, any help would be greatly appreciated.

    • JakeC
      Ansys Employee

       Hi nuchizono,


      Can you please post screenshots of the following logs:


      c:program filesansys incshared fileslicensinglicense.log


      c:program files ansys incshared fileslicensingansysli_server.log


       


      Thank you,


      Jake

    • nuchizono
      Subscriber

      Here is c:program filesansys incshared fileslicensingansysli_server.log 


      https://photos.app.goo.gl/ZGyDu4yBhejUMHFH9


      I do not have a c:program filesansys incshared fileslicensinglicense.log


      which i assume may be the issue.

    • tsiriaks
      Ansys Employee

      Please post the screenshot here as ANSYS employees are not allowed to access/download files from file hosting server.


      The license.log would be generated when the FlexNet tried to start. This means it didn't even try.


      Please try killing ansysli_server and ansysli_monitor processes from your Task Manager, then rename the following file


      c:program filesansys incshared fileslicensingansyslmd.ini


      to anything else (make sure it doesn't end with .ini) 


      Also, what is the content of the file above ?


      You can try installing the license file again after renaming this file.


      Thanks,


      Win

    • nuchizono
      Subscriber

    • nuchizono
      Subscriber

    • nuchizono
      Subscriber

      The contents of c:program filesansys incshared fileslicensingansyslmd.ini are as follows:




      ANSYSLI_NOFLEX=1


      LICKEYFIL=C:Program FilesANSYS IncShared FilesLicensinglicense.dat



    • tsiriaks
      Ansys Employee

      rename the ansyslmd.ini and reinstall your license file again.


      Thanks,


      Win

    • Sushant
      Subscriber
      Ok sir i do that but when i start my workbench in 19.2 the system error "0" occur...and licence file is not uploading successfuly.
    • tsiriaks
      Ansys Employee

      Please create a new thread and post the screenshot of the error. Also, mention in that post if you have Academic (paid) license.


      Thanks,


      Win

Viewing 9 reply threads
  • You must be logged in to reply to this topic.