Electronics

Electronics

Problem with FluxLines and Torque of a PSM

    • Sebastian
      Subscriber

      Dear ANSYS Community


      I have a problem using ANSYS Maxwell to simulate a PSM with 4 poles. I saved the Maxwell File as attachment here.


       


      I have a distributed 3-phase winding in the stator and a 4 pole rotor with permanent magnets. These magnets has an own coordinate system due to the Motion Setup of the rotor. Caused by a stator frequency of 100Hz the motion setup speed is 3000rpm.


      When thesetup is solved you cansee that theTorque is not feasible and the flux line distribution gets weird over the time. What could be the reason of this behavior?


      I appreciate your help. Thank you very much.


      Sebastian

    • Mark Solveson
      Ansys Employee

      Plot the current waveforms, the Branch Current shows the current probe currents, there may be a missing current source?  
      Note that when using the circuit editor with current sources, that a large (1e6) parallel resistance across each current source may be required.  Else using Current excitation, instead of an external circuit, with grouped windings may be another approach.   


      Check that the time step is small enough to capture the rotation and the frequency of excitation, about 20 time steps per cycle is a good starting point, 1ms time step may work better.  


      Also, be careful that the Band does not intersect with the Rotor, this may cause meshing difficulties, making the band object of slightly larger radius may help.  

    • Sebastian
      Subscriber

      Hi Mark,


      thank you very much for posting your ideas. I found out that I set eddy currents in Stator and Rotor. This effects a weird field distribution.

Viewing 2 reply threads
  • You must be logged in to reply to this topic.