Ansys Products

Ansys Products

Problems using 2022/R2

    • rainwadj
      Subscriber

      I have a researcher who is unable to use Ansys 2022/R2, specifically the Mechanical application.  After entering the 'runwb2' command, he opens his project file, then double-clicks the Model entry under Static Structural.  The first issue is that we see no geometry model in the viewer like we should (circled red). This is confirmed by hitting the 'Zoom-To-Fit' button which will fit the imported geometry in the graphics viewer (crcled yellow). Secondly, a 'Ruler' should be located in the black circled area. Third, a 'Triad' (3D axis showing direction of x, y, and, z) should appear in the green circled area. I ensured that those options are enabled so they should be in the graphics window. Lastly, if you click the '+' next to 'Geometry Imports' (circled purple) to expand the list of geometry imports and click on 'Geometry Import (B3)', the Mechanical application crashes and the terminal reports the fatal error.

      This is all on Linux (CentOS 7).

      Any ideas?

       

    • rainwadj
      Subscriber

      We also tested this with 19.2, and it works as it's supposed to.

    • Rob
      Ansys Employee

      I suspect it's OS graphics related, which verson of CentOS 7 are you using?  https://www.ansys.com/content/dam/it-solutions/platform-support/ansys-2022r2-platform-support-by-application-product.pdf

    • rainwadj
      Subscriber

      I'm on version 7.9 of CentOS.

    • Rob
      Ansys Employee

      It should work, I'll flag for installation to check. 

    • George Karnos
      Ansys Employee

      Hello,
      If the graphics card is listed as tested:
      https://www.ansys.com/content/dam/it-solutions/platform-support/ansys-2023-r1-graphical-display-graphics-cards-tested.pdf


      I would recommend updating the graphics card driver to the latest.

    • rainwadj
      Subscriber

      I have found that it works correctly if I run it directly on the physical workstation.  The problem only seems to occur when I connect to the workstation with VNC to run it remotely.  This worked correctly in 19.2.

       

    • George Karnos
      Ansys Employee

      Which version of VNC are you using?
      https://www.ansys.com/content/dam/it-solutions/platform-support/previous-releases/ansys-2022-r2-remote-display-and-virtual-desktop-support.pdf

    • rainwadj
      Subscriber

      On the workstation, I have tigervnc-server installed.  On the client, a lot of the users are on Windows with RealVNC.  I'm a Mac guy myself, so I've tried with the built-in Screen Sharing app over an ssh tunnel.

      I've also tried using RDP, with xrdp installed on the workstation and Microsoft Remote Desktop as the client.  This fails... differently. After loading the project, I double-click the Model line, and it says "Starting Mechnical" at the bottom of that window, but when it opens the second window, it's mostly just a smear.  See attached.

    • rainwadj
      Subscriber

      Any ideas on this?

    • Mangesh Bhide
      Ansys Employee

      Please try prepending the path to Mesa folder to LD_LIBRARY_PATH

      example: Is Ansys is installed to /nfs/apps/ansys_inc/v221/Framework/bin/Linux64/Mesa and LD_LIBRARY_PATH is set to say /a/b:/1/2 etc etc
      then set

      LD_LIBRARY_PATH=/nfs/apps/ansys_inc/v221/Framework/bin/Linux64/Mesa:/a/b:/1/2 etc etc

      then try launching Workbench. I would expect Mechanical to show graphics, but this will be using software rendering and slow. if slow, please look into graphics hardware and remote display methods which support hardware graphics acceleration

      Note: a and b and 1 and 2 are not real folders and you need not set those, this is just an example to denote your existing path which may contain many such eentries separated by a colon

    • rainwadj
      Subscriber

      Most of the workstations have AMD Radeon RX 4xx cards in them.  I have updated one of them to the latest driver (version 22.40 released 12/13/2022).  No luck with either VNC (black panel where the graphics should be, but the rest of the interface is normal) or RDP (smeared graphics when the Mechanical window is opened).

      I tried adding the Mesa directory to LD_LIBRARY_PATH just before running Ansys, on both a VNC connection and an RDP connection, and the results are the same as above.

       

    • rainwadj
      Subscriber

      I also tried running the same project on that system with Ubuntu 20.04, and the results are the same for VNC.

Viewing 12 reply threads
  • You must be logged in to reply to this topic.