General Mechanical

General Mechanical

Problems with mechanical analysis

Tagged: ,

    • Max Winger
      Subscriber

      Hi there,

      I am currently running into some issues with workbench 2022R2.

      Short story is that I probably have some issues with the solver configuration. You can find the problem description below. Anyways, I am going to describe the long story at first, because there could be many factors resulting in the problem:

      Workbench is installed on an machine of my university, which I can access remote. That computer has the full ANSYS license with every module you can get. I was already simulating with the static- mechanical- analysis for quite some time without any problems. Since this computer does not have Autodesk Inventor installed as a CAD program (I am using Autodesk Inventor on my private computer), I could not use the ANSYS interface for importing Inventor models to workbench. Still I could not just import my models as STEP files because I had to do direct optimization in ANSYS- based on parameters that are defined in the sketches of my CAD model. So I always built my CAD models directly in Design Modeler (the first models weren't that complicated). About a week ago I generated the final CAD model based on the solution that I found with ANSYS.

      I used all the solutions to set up an Inventor assembly that contains the whole model (not just the geometry I optimized with ANSYS) plus some screws. And this is where my problems started:

      At first I just imported the assembly as STEP data to ANSYS and simulated the model with defining contacs, screw pretension etc. This worked out fine, but of course the values weren't as perfect as in the optimization before. So last step would be to direct optimize the whole assembly- again based on the parametric sketches. But this model is way to complex to rebuild it in Design Modeler, so I did the following:

      I installed ANSYS education on my private computer. This enabled me to install the ANSYS Inventor plug in and import the parametrized assembly model to ANSYS workbench education. Then I saved the project and copied it to the university computer that has the full ANSYS license. On this computer I set up a staic- mechanical- analysis- EXACTLY the same like I did with the STEP file.

      However, the analysis can not be solved anymore!!! I always get the same error codes:

      • Directly after starting I get the warning: "could not move data from solver- directory to the scratch directory: file0.rst" (Translated from German, original message: "Fehlgeschlagen Verschiebender Datei aus Solver-Verzeichnis in das Scratch-Verzeichnis: file0.rst")
      • After about 40 seconds I get the warning: "The status of contacts has suddenly changed, carefully check all the contacts" (German original message: "Der Kontaktstatus hat sich plötzlich geändert.  Überprüfen Sie die Ergebnisse sorgfältig auf eine mögliche Trennung von Kontaktflächen.")

      What I did:

      • I checked every single contact. I set up my screw contacts with the bond- contact between the screw shaft and the main parts lateral surface of the thread. Also I defined a bond- contact between the screws head an the related surface on the part that is mounted to main part. Finally there is a contact with friction between those two parts taht are held together with the screws. Because of the warning referring to the contact status I changed every contact step by step to "no speration" (in German: "keine Trennung"). But nothing changed. There is no part that suddenly looses its contact ?!!
      • I checked all the pretension conditions. But they were set up correctly in two steps (first step the pretension rises, second step the screws are locked and then the force is applied)
      • I tried to simulate with low forces and weak spring mode. Still no convergence.

      The program calculates for about 20 minute and then stops with saying there is no convergence. The previous analysis of the STEP file was taking 2 minutes and had no warnings or other issues.

      Could the problem be, that some configuration path of the program is still set to my own computer? That would maybe refer to the warning with the file0.rst?

      Also I have to admit that I really just copied the project file and the project_file folder from my private computer to the university computer with "copy paste". Would I have to somehow export the project?

       

      I really have no more idea of what I can do. By now I put in many hours to solve the problem but I just can't get any further. So I really hope there is someone that can reach out. Let me know if I should send any files.

      Greetings,

      Max

    • Aniket
      Ansys Employee

       

      Hi Max,

      So you are using the free student version (https://www.ansys.com/en-in/academic/students/ansys-student) on your private machine, is that right? Is that what you mean by “ANSYS education”?

      If yes, it does not support any CAD interfaces. I am not sure how you configured them, but the free version only supports the following formats for geometry:

      Am I missing something here? You can attach your files here, but please note, Ansys staff can not download any files on the forum, so if you want to reach a larger audience to get answers from, please insert inline images describing your problem.

      -Aniket

      How to access Ansys help links

      Guidelines for Posting on Ansys Learning Forum

       

    • peteroznewman
      Subscriber

      Hi Max, I have seen the “could not move data from solver- directory to the scratch directory” warning before. I’m not sure why I got this warning, but it solved anyway on the laptop. Since the solver directory and scratch directory was on the same computer, it didn’t take longer to solve.  If you are on a University network, maybe the solver directory is on the local workstation, while the scratch directory is on the remote computer, the time for solving may increase due to slow network speeds compared with the fast access to the local SSD. This is just a guess.

      The safe way to move projects between computers is to use File, Archive in Workbench which creates the .wbpz file. This one file can be moved between different computers and is better than moving the .wbpj file and same named _files folder.

      A small change in the way a part was meshed can make a contact that was Closed on the first mesh to be Near Open with a tiny gap on the next mesh. When the solver closes this gap, in the first substep, the message “The status of contacts has suddenly changed” is issued. This is not a problem if the solution keeps going.

      There are lots of reasons why a model will fail to converge. It helps to see an image of the Force Convergence plot.

      While Workbench can’t directly import into the Geometry cell anything except a STEP or IGES file, if you open SpaceClaim, you can then open a long list of CAD formats including Autodesk Inventor files, but this will be the solid geometry and not the underlying sketches and parameters.

      The direct CAD interface to Inventor is not supposed to be included in the free Student license, but maybe there was a mistake building that version and it was accidentally included.

    • Max Winger
      Subscriber

      Hi there, thank you very much for the response.

      Yes I am using the free student version and I did recognize that you would only be able to import STEP and IGES. Still I tried setting up the Inventor interface and it worked out just fine... :D (don't tell the ANSYS employees).

      Creating an archive file seemed to be a good hint. I just finished preparing the model for analysis based on this archive file some hours ago. So the current project should be clean of any data location/ path mistakes.

      Anyways is there a menu in workbench showing the relevant paths? I would like to check your guess with related directories being on both the local workstation and the remote computer. Still I don't think this is the case because I never had a problem with turning off the connecting between my remote PC to the workstation while solving.

      I started with meshing straight after making sure everything was set up right (That was about 2 pm today). Strangely enough that meshing process is still running (although it is running on the very fast machine at the university). I never had a mesh that was taking more than a minute by now. Process is working but I am probably going to stop it, if it has not finished by tomorrow morning.

      I am not sure what this behaviour comes from. For sure I will be checking if I did any mistake but as I can see, mesh size is at 1 mm and every setting is just like before.

      Going to keep you updated.

      Greetings,

      Max

    • Max Winger
      Subscriber

      Ok so meshing was still calculating this morning so I stopped it. Restarted the application and tried again- mesh was being calculated within a few seconds this time. So this went alright.

      I then started solving and of course nothing changed. Even with creating a mesh that has huge elements there is no solution. You can check the solver information with the following link- for sure I tried to figure out whats wrong on my own, but it is very cryptic to me:

      https://we.tl/t-bSSLDwn9i6

      Meanwhile this issue is really over my head. Does anyone has some tips what I can try to do? Also I attached a picture of the model so you can see the contacs I am talking about. Basically there are the contacts between the screws, that I wrote about before. In addition there is the friction between that two outer parts and the middle part. And lastly I set up a bond- contact between the outer part that is fit to the middle part with this litte "step/ overhang". I changed all those contact types variously but there is just no way to get the simulation running. Still I think it has something to do with the contact settings, because despite the contacts there is just not much complexity to the analysis.

      Just let me know, if there is some more information I need to provide.

      Hope someone can help,

      Max

    • Max Winger
      Subscriber

      One thing I forgot to mention:

      I do get the analysis to solve when suppressing every contact and pretension setting and just generate automatic contacts. That solution does not make much sense but it is not getting cancelled due to no convergence.

      Maybe one of the expert users can tell me how they would set of the contact definitons in the model I presented above?

      Greetings,

      Max

    • Max Winger
      Subscriber

      Another update: Simulation succeeded by creating a workaround. Since the problem probably results from the screws, I just replaced them by a simplified geometry. Also I reduced the middle part on the minimum of complexity. With those modifications the simulation is running perfectly fine.

      Unfortunately I can't update parameters....

      As I mentioned before, I created the geometry in Inventor, then importet to ANSYS and in ANSYS I opened the file with Design Modeler. This enabled me to activate the parameters. Now when I am trying to modify parameter values and then refresh Design Modeler there is an error saying "update failed". After this the whole model vanishs from Design Modeler and I have to restart the project with the old parameter settings.

      This is a big problem because with the direct optimization feature in workbench I need to be able to change the model by updating parameters.

      I read about Design Modeler would only accept CAD models, when those models are built in a CAD program that runs on a previous version in relation to Design Modeler. But my Inventor is the 2023 version and ANSYS is 2022. Does that really cause such issues?

      Would appreciate some information.

      Greetings,

      Max

Viewing 6 reply threads
  • You must be logged in to reply to this topic.