General Mechanical

General Mechanical

Relevance vs. Resolution

    • AgTKl
      Subscriber

      Hello everyone!


      I have a problem "translating" Relevance option in Mesh from previous Workbench versions to the newest 19.2. I'm following Prof. Huei-Huang Lee's book (based on Workbench 17) and I'm stuck in Section 6.1. The instruction is to set Relevance to -60 in order not to exceed 32000 nodes/elements (which is the limit for student version of the software). I solved that problem previously in another exercise by choosing "yes" for Sizing/Use Adaptive Sizing in Mesh Details and adjusted Resolution until I got approximately the same number of nodes and elements as specified in the book. This time it didn't work, I keep getting an error message. Attached are 3 screen shots. I would appreciate any suggestion for solving the issue.


      Kind Regards


      Agata


       



       


       



       


       


    • tsiriaks
      Ansys Employee

      Hi AgTKl,


      I think the size limits are based on node/element numbering and not amount of nodes/elements. There are probably gaps in the node or element numbers.


      Try this, right-click the Model object, then Insert a Mesh Numbering.  Make sure 'Compress Node Numbers' in the the Details is set to 'Yes'.  


      Thank you,


      Win

    • AgTKl
      Subscriber

      Hi Win,


      thank you for the suggestion. Unfortunately, it didn't work.


      Kind Regards


      Agata

    • tsiriaks
      Ansys Employee

      Hi Agata,


      Thanks for the update.


      In that case, I would recommend to post this question in either


      Pre and Post Processing -> Mesh Generation


      or


      Physics Simulation -> Structural Mechanics


      You would get more response there.


      Thanks,


      Win

    • Keyur Kanade
      Ansys Employee

      Moving to structural mechanics category to get better response. 

    • Aniket
      Ansys Employee

      This is strange! As you have mentioned the limit is 32K nodes or elements. Can you write an input file for this model and check nodes in the resulting dat file?


      For writing this input file, click on the solution branch of the tree, and then go to tools and write input file. If you are able to write the file, open it any text editor and find nblock command and see the NDMAX field. (generally, the last field in the command e.g. nblock,3,,3829)


       Judging by the similar number of nodes and elements in your mesh, are you using surface bodies (shells) in the model? If yes, instead of using global controls to control the mesh size you can use local controls (such as body size or face size) where you can fine tune to reduce the NDMAX number to something below 32K.


      Please try to reduce the node count using local sizing controls so that the NDMAX is below 32K and see if that helps.

    • AgTKl
      Subscriber

      Hi Aniket,


      thank you for your suggestion. Yes, I'm using shells in the model. I don't know how to "use local controls" and I couldn't find "body size" option. Could you please tell me in more detail how to find these setting? I solved the problem (for the most part) by selecting Mesh Control/Sizing and selected all the inner faces. In the tree under Mesh "Face sizing" appeared. I had to reduce the Resolution from 4 to 3 because I got a little over 32000 nodes and elements. The problem is, now I have about 15000 nodes and elements each, which is significantly less than before.


      Kind Regards


      Agata


      *Edit: I added the info about Resolution change

    • Aniket
      Ansys Employee

      AgTKl,


      Yes, I meant face sizings or body sizing as local controls. You can have a better control over the mesh size using the face/body sizing (instead of using the only resolution control in global mesh controls)

    • AgTKl
      Subscriber

      Great, thank you for your help!

    • imohitthakur
      Subscriber
      Can someone share Prof. Huei-Huang Lee's book. Been trying to find it for a long time.n
Viewing 9 reply threads
  • You must be logged in to reply to this topic.