Remedying divergence issues for low permeability/high SV ratio materials with moving mesh

    • julia.hartig
      Hey all I've been using a 2D reacting porous media model with dynamic meshing for some time without issues. To give an overview - we are modeling a moving packed bed of particles (porous media #1) traveling over a porous baseplate (porous media #2) in a reactor that vibrates sinusoidally in two dimensions (see first attachment). During extension (right and up motion), everything moves together. During retraction (left and down) motion, the moving packed bed of particles moves from left to right relative to the reactor. We also has gas-solid reactions occurring in each porous media - precursor gas (trimethyl aluminum or TMA) passing through the porous media reacts with hydroxyl surface groups to deposit oal(ch3)2 and evolve methane gas (ch4). I have used this model successfully for permeability viscous resistance values k_baseplate = 3.625*10^11 (1/m2) and k_packedbed = 2.353*10^10 through k_packedbed=2.353*10^12, but when I try to use larger values (on the order of 1E13 and 1E14) I run into issues.
      The simulation seems to run successfully with adaptive, CFL-based (first-order implicit) time stepping until the moving mesh begins to relayer around 76 ms, at which point we see divergence in the continuity equation (see "hot spots" in the unconverged y-velocity output in second attachment). Smaller time steps don't seem to help, and since we're already using adaptive time stepping, I'm not sure what else to try? My underrelaxation factors are at the default values; in the past I haven't found changing these helps much, but maybe that's because of my lack of experience!
      Let me know if anyone has ideas, not sure how to hunt down a solution at this point.
    • RK
      Ansys Employee


      What are your dynamic mesh settings? I would suggest writing out the motion history and see the mesh movement to get an idea if you can tweak any of the dynamic mesh settings. 

Viewing 1 reply thread
  • You must be logged in to reply to this topic.