Ansys Products

Ansys Products

RSM Configuration with Multiple Network Card in ANSYS Electronics Desktop 19.1

    • NEWCYP
      Subscriber

      I'm configuring the RSM in Ansys Electronics Desktop 19.1. My computer has multiple network cards, so it has multiple ip addresses.


      Here is part of the result when I test the local machine.



      • Checking AnsoftRSMService availability on machine localhost

      • AnsoftRSMService is alive

      • This machine has multiple network cards. Additional configuration may be required...

      • The IP addresses for this machine are:

      • 10.147.17.1

      • 192.168.1.188

      • AnsoftRSMService is listening at 10.147.17.1 : 32958


      As you can see, the RSM is running on ip 10.147.17.1. But I need it to run on ip 192.168.1.188.


      I tried Tools->Option->General Option->General->Remote Analysis->Specify the ip in Desktop-Engine Connection. And then I un-register and re-register the RSM service. It still uses 10.147.17.1 address. I tried restart my computer, re-install RSM, etc... All didn't work.


      So I'm here to ask how can I specify an ip address for the RSM server? Is there any command line options or config options to do that?


      Many Thanks!

    • ANSYS_MMadore
      Ansys Employee

      Hello,


       


      When you set Tools->Option->General Option->General->Remote Analysis->Specified Address, in Desktop-Engine Connection, it will use this when actually running the analysis.  The service may be listed as running on one IP, but it will receive the communications through the designated IP.


       


      Thank you,
      Matt

    • NEWCYP
      Subscriber

      Hello,


      When you set Tools->Option->General Option->General->Remote Analysis->Specified Address, in Desktop-Engine Connection, it will use this when actually running the analysis.  The service may be listed as running on one IP, but it will receive the communications through the designated IP.



       


      Thank you for the reply Matt. I think your solution should be the right answer.


      Before I test your solution, I solved this issue by temporally disable all other network cards, un-register RSM, uninstall Electronics Desktop and delete all remaining configuration files, re-install Electronics Desktop and register RSM. Then it will use the designated IP, and it still works after I enable all other network cards.


      And for other Windows RSM users: Please make sure set the network profile to 'Private' instead of 'Public', otherwise the RSM service will be blocked by Windows firewall.


       


       


       


       

Viewing 2 reply threads
  • You must be logged in to reply to this topic.