Ansys Products

Ansys Products

RSM failed to verify my credintials when connecting to the cluster

    • MohdElhashimi
      Subscriber

      Hello,


      I've been trying to connect my machine to the cluster through the Ansys Remote Solve Manager (RSM). The HPC type is UGE(SGE).  I believe my configurations are all correct and I confirmed that with another research group that runs the same thing but it's just not working for me.


      I checked the connection through the "telnet" command and it's working well. Also, my connection via MobaXterm is smooth. When I reached to the queues tab in the RSM configuration I get the attached error.



      "System.InvalidOperationException: Timeout getting UseerProxy port for user ... [machine name] on submit-c..."



      What might be the problem?


       


      Thank you all.


       



       

    • tsiriaks
      Ansys Employee

      Check with your cluster admin to see if anything blocking ports. There are a lot of different ports being used. I think you can connect to RSM Launcher service port 91xx but you have issue connecting to ports used by User Proxy, which handles files transfer , etc. Ask your cluster admin to check file


      (default location) /ansys_inc/v1xx/RSM/Config/Ans.Rsm.AppSettings.config 


      for these lines


      "PortRange" value=""


      "SocketTransfererPortRange" value=""


      by default these are blank, meaning it will always change ports. Your cluster admin can specify the ranges here and make sure the ports in these ranges are open. Please note to them to restart RSM Launcher service after modifying this file.


      Note: This should be done on the submission (head) node.


      Let us know how it goes.


      Thanks,


      Win


       

    • MohdElhashimi
      Subscriber

      Thank you for the response. That looks like something that might affect all the cluster users. There are other groups running fluent simulations on the cluster without having my issue. So is that config. file shared among all the users ?


       

    • MohdElhashimi
      Subscriber

      That's what our cluster admin response:  



       


           Default ports are usually greater than 50000.  This option may be required
              for environments where upper port range is restrictioned by firewall.  e.g. "1000-2000"
          -->
         


      and for the other line:



      Do you think the problem is the port we're using (9192) is way off that range?

    • tsiriaks
      Ansys Employee

      Thanks for the info.


      The 9192 is the fixed port used by RSM Launcher v19.2 service


      The issue you are having is with ports used by User Proxy. Unfortunately this is randomly assigned because it's a range of ports. 


      the two main lines are


      "PortRange" value=""


      "SocketTransfererPortRange" value=""


      If nothing is set, it will randomly use any port.


      Note: ProxyXmlRpcPortRange" value="50000-50100" is a different port range used by a different component of RSM. Not the user proxy that I was talking about.


      Thanks,


      Win

    • lennartm
      Subscriber
      Should these ports have different ranges?nI have now set: nnn
Viewing 5 reply threads
  • You must be logged in to reply to this topic.