Fluids

Fluids

Running a two-way coupled FSI on linux HPC cluster

    • ReneHiemstra
      Subscriber
      Hello all, I've been bashing my head against running a two-way coupled analysis on our local HPC. I've tried reading and applying the various command line tutorial but those get me stuck as well sadly. My predecessors here used system-coupling in an old ansys version(17.1). But now we are working with a newer version, 2019r1 and I have no documentation available to me to pull this off. I've extensively tried to follow the oscillating plate tutorial with command line options provided to me by Ansys, but I can't get it to work for me.

      I have the following files:

      1. Fluent.cas file
      2. Mech.dat file
      3. Coupling.sci file
      4. A journal.jou file for fluent
      5. a Shell file to submit the simulation to the cluster
      6. and lastly a .py file to give commands for system coupling.
      My shell file does not have much information in it, just some basic IO and the following command:
      /opt/ud/ansys-2019r1/v193/SystemCoupling/bin/systemcoupling -R inputfile.py &
      Where the inputfile.py looks like this:
      1 importSystemCouplingInputFile(FilePath = 'Coupling.sci')
       2 execCon = DatamodelRoot().CouplingParticipant
       3 execCon['Solution'].ExecutionControl.InitialInput = 'Mech_FSI_A1.dat'
       4 execCon['Solution'].ExecutionControl.WorkingDirectory = 'struc_run'
       5 execCon['Solution 1'].ExecutionControl.InitialInput = 'Fluid_body.cas'
       6 execCon['Solution 1'].ExecutionControl.WorkingDirectory = 'fluid_run'
       7 execCon['Solution'].ExecutionControl.PrintState()
       8 execCon['Solution 1'].ExecutionControl.PrintState()
       9 Solve()
      The only output this gives me sadly is: sed: couldn't flush stdout: Broken pipe My predecessor worked with an older version, but too be fair, I'm a bit over my head here and I don't know where to start to get this to work. Before I used a totally different shell file: which used the following commands(leaving out file I/O)
       45 module load ansys/2019r1
       46 module load mpi/openmpi-1.8.8-gnu
      49 /opt/ud/ansys-2019r1/v193/aisol/.workbench -cmd ansys.services.systemcoupling.exe -inputFile ${COUP   LING} &
       76 fluent 3ddp -rsh -t ${NPF} -g -cnf=${PBS_NODEFILE} -scport=${HOSTPORT[0]} -schost=${HOSTPORT[1]} -s   cname="${JOB[4]}" -i journal>& output.FLUENT &
       86 ansys2019r1 -b -scport=${HOSTPORT[0]} -schost=${HOSTPORT[1]} -scname="${JOB[2]}" -i Mech_FSI_A1.dat    -o output.Ansys -np ${NPA}
      The problem here sadly is that the simulation would just close with the following error:
      244 DBG | (Name, Host, Port): (4, n**-**, *****)
      245 DBG | Request served - Scanning to see if all required service providers have been registered...
      246 DBG | Last provider to connect: 4
      247 DBG | Connection from provider '4' not expected. Notifying and disconnecting provider.
      248 DBG | Connecting to service provider: 4
      So I was stuck there as well, and as i understand from other forum posts the above mentioned method is outdated and no longer supported.

      Summary:

      Have all the needed files for my FSI simulation but cannot get the command line setup to execute the simulation on my HPC. Hoping that someone can point me to a good tutorial or to what I am doing wrong here. With Kind Regards, Rene Hiemstra
    • DrAmine
      Ansys Employee
      Why don't you have a documentation? I will encourage to check the SystemCoupling 2.0 Tutorials.nn
    • Jirong
      Subscriber
      Hi Rene Hiemstra,nI'm also trying to run a FSI on my school HPC cluster. Did you figure it out?n I didn't Python to drive system coupling to run. I used this script https://support.nesi.org.nz/hc/en-gb/articles/212642617. But I also faced some problem, such as mapdl cannot connected to system coupling service even though I specified the host name and node name. nLet me know if it helps.Best,nJirongn
    • Stephen Orlando
      Ansys Employee
      Hi Rene,nSorry to hear about your head; I'm sure we can help you out.nI'm seeing some differences with the names in the inputfile.py and the instructions in the tutorial here. https://ansyshelp.ansys.com/account/secured?returnurl=/Views/Secured/corp/v193/sysc_tut/sysc_tut_oscplate_commandline.html. I recommend following the tutorial exactly to avoid any issues. Also, I recommend first getting this tutorial to run on your local machine before running it on your HPC cluster. Once you get the known tutorial running locally, then the HPC run can be debugged.nCan you give some more details on the local HPC? Does it have a job scheduler or do you have access to all nodes?nSteven
    • ReneHiemstra
      Subscriber
      Hey guys,Thank you for your response, it's been some time since I posted this message but i've managed to fix the error, the problem was in version control with the cluster using a different version than I was using locally. Thank you guys for your support!nnkind regards,nnRenen
Viewing 4 reply threads
  • You must be logged in to reply to this topic.