Fluids

Fluids

Running Fluent on Remote Linux Nodes

    • kmkb21
      Subscriber
      I am attempting to run ANSYS Fluent from Windows using remote linux nodes. I'm attempting to run using the PBSPro scheduler, though ideally I would use Slurm which is on the cluster I'm attempting to use.
       
      Even with PBSPro selected, the output from Fluent says "It seems ssh is trying to verify authenticity of @. Please resolve it and try again!"
       
      I have set up passwordless ssh on the machine, and changed the environment variables so that the key path and the PuTTY path are present.
    • Rob
      Ansys Employee

      Is this a shared memory machine, or several independent boxes? You may need to speak to IT as it's possibly something on the systems side. 

    • bhagrawa
      Ansys Employee

      How are you checking your passwordless access?  Are you sure that Fluent is picking up the same ssh for which you've set up the passwordless access?

    • kmkb21
      Subscriber

      This is a shared memory machine. I have discussed it with IT and they have suggested using script-based setup, which I have now done.

    • kmkb21
      Subscriber

      I have used PuTTY and WIndows Subsystem for Linux, though as I have said I have now used scripts which appear to be working correctly and no longer need the GUI for setup.

    • ganderaj
      Subscriber

      Hey kmkb21,

      I am trying to deploy a cluster for ANSYS Fluent where we would like to submit jobs on the Cluster Head Node by sitting on a remote Windows Box using SGE Scheduler. I have setup passwordless connection from Windows to Head Node and from Head Node to Compute Nodes. I have configured ssh with not having to ask for authenticating the SSH. Yet I see the same error mentioned above- "ssh is trying to verify authenticity of @. Please resolve it and try again!" I see that you have overcome that issue by making use of a script. I would greatly appreciate it if you could help me with the Scripts.

      Thanks in advance.

    • bhagrawa
      Ansys Employee

      You may have done passwordless set up for different ssh.exe than the one Fluent picks. You can try full paths for passwordless setup (for example, c:cygwin64binssh-keygen.exe) and Fluent launch:


      launching from the command line, use the -rsh option (for example, -rsh=c:cygwin64binssh.exe); using Fluent Launcher, select Other from the Remote Spawn Control list in the Remote tab and enter the path in the text box (for example, c:cygwin64binssh.exe).


       

    • kmkb21
      Subscriber

      Hi there


       


      I was able to use a script input for a remote linux node and used commands from the Fluent TUI to launch and run each of the simulations, in which I specify a file to read in the commands. This will differ depending on the scheduling on the cluster you're using. I am afraid I was not able to resolve the verify authenticity issue. Has the official reply helped you resolve your issue?


       


      Cheers

Viewing 7 reply threads
  • You must be logged in to reply to this topic.