Fluids

Fluids

Save-picture TUI command randomly fails

    • julia.hartig
      Subscriber

      I've been having a recurring issue with the save-picture TUI command. I currently have a series of 'Execute Commands' that display a contour plot and then save it to a .jpg file every 10 time steps with the title 'mfVOF-%6t.jpg'. I've noticed that for some reason, where I save my case file seems to affect whether or not this TUI command works. Sometimes this code executes with no error, other times I get the message "CX_Hardcopy_Window: error opening JPEG file mfVOF-######.jpg" and no image is saved. It seems to me like the path file to Fluent's image-writing software is hard-coded or otherwise programmed such that it can only be located when my case file is stored in certain locations. I always start Fluent Launcher from the Command Prompt so I know that the 'Working Directory' and 'Fluent Root Path' are not the issue, as these reference the correct file locations. How can I fix this problem? Is there some way I can check what directory Fluent is using to search for the image-writing code?

    • DrAmine
      Ansys Employee

      Fluent used local paths so that the pictures are stored in the working directory if not explicitly defined to be done in another directory. I usually recommend creating a sub-directory where I save my pics: ./vofpic/test-%f.jpeg. I recommend making some debugging and start from the directory where the case is located.

    • julia.hartig
      Subscriber

      That was it! I guess I had some case files saved in working directories that Fluent couldn't write to, so I changed the 'mfVOF-%6t.jpg' part of the code to always save images to the same file path on my C drive and now I have no errors. Thank you!

Viewing 2 reply threads
  • You must be logged in to reply to this topic.