Topics relate to Fluent, CFX, Turbogrid and more

Scheme loop has wrong interaction

    • 22503862

      I have the following loop to save pictures:


      (do ((x 1 (- x 0.5))) ((< x -2))
              (ti-menu-load-string (format #f "/display/objects/edit contour surfaces-list (z=~a)" x))
              (ti-menu-load-string (format #f "/display/objects/display contour"))
              (set! x (* x 1000))
              (ti-menu-load-string (format #f "/display/save-picture ./pictures/velocity-contour-z=~a" x))
              (set! x (/ x 1000))


      except that it doesn't work. after the (z=~a) in the first line, the surfaces selection does not stop. It actually enters the rest of the commands as one giant string which is plain stupid. I tried q, I tried (), nothing works. what is going on?


    • Luca B.
      Ansys Employee

      Hi, what version are you using? please double check the TUI commands ( line 2 ) because it seems not to be updated to the last version.

      It should be something like (ti-menu-load-string (format #f "/display/objects/edit contour surfaces-list ~a () () " x))

      The behavior you reported is expected, but it should not limit the funcionality. Add a space at the end of each line se correctly separate the commands.


Viewing 1 reply thread
  • You must be logged in to reply to this topic.