Ansys Products

Ansys Products

Discuss installation & licensing of our Ansys Teaching and Research products

Set the environment variable FLUENT_ARCH and try again.

    • rt1

      Hi All,

      I am administration on a small CentOS8 (8.5.2111) cluster at my University.

      I have added to my bashrc file the following:

      FLUENT_ARCH=lnamd64 export FLUENT_ARCH

      export PATH=$PATH://applications/Ansys-2022.R1/ansys_inc/v221/fluent/bin/

      When I submit a fluent job the the cluster using SLURM the job refuses to run but does not generate an error just the following output:

      /applications/Ansys-2022.R1/ansys_inc/v221/fluent/fluent22.1.0/bin/fluent -r22.1.0 2ddp -t4 -mpi=openmpi -i /home/admin/ANSYSTEST_v3//_read_fluent_case_.jou -nm -ssh -license=premium -cnf=slurm.125.hosts

      /applications/Ansys-2022.R1/ansys_inc/v221/fluent/fluent22.1.0/cortex/lnamd64/cortex.22.1.0 -f fluent -nm -license=premium -i /home/admin/ANSYSTEST_v3//_read_fluent_case_.jou (fluent "2ddp -pethernet -host -alnamd64 -r22.1.0 -t4 -mpi=openmpi -cnf=slurm.125.hosts -path/applications/Ansys-2022.R1/ansys_inc/v221/fluent -ssh")

      If I run these commands via the command line I get the following error:

      Error: directory /applications/Ansys-2022.R1/ansys_inc/v221/fluent/fluent22.1.0/fluent22.1.0 does not contain a valid arch.

      Set the environment variable FLUENT_ARCH and try again.

      What am I doing wrong?


    • Hunter Wang
      Ansys Employee
      FLUENT_ARCH=lnamd64 is usually not required.
      How exactly did you submit Fluent job SLURM? Using job script, Fluent command line, or any other ways?
      Try default Intel MPI by removing -mpi openmpi to see how it works?
      Refer for more details.
    • rt1
      I submitted it via bash in a terminal.
      I tried removing -mpi=openmpi and also -mpi=intel but in both cases I still get the same error.
      It looks like the version of slurm I have installed is not supported (slurm-20.02) so I'll try updating to (slurm-20.11).
      Do you know if slurm-21.08 is ok it not shown on the list?
Viewing 2 reply threads
  • You must be logged in to reply to this topic.