Fluids

Fluids

solid-fluid interface

    • hamda
      Subscriber

      Hi,


      In my problem, I have defined 2 domains; solid domain (spheres) and fluid domain (the space between them).
      In sub domain I have defined heat source but I have a problem with its unit! I mean my unit is (w/m3) but in CFX (W). In fluent I didn't have such problem because in it the unit was (w/m3). Do I have to  write an expression for it?

      Also How can I sure that I have a solid-fluid interface for my problem? indeed this is the main point to me!

      Many thanks in advance


    • Rob
      Ansys Employee

      Which solver are you using, and what heat source are you trying to apply?

    • hamda
      Subscriber

      Thank you for reply.


      I use CFX (14.5). I should do 2 simulations , first for a constant heat source and second for a heat source that is a function of time. 


      currently  my problem is not related to  heat source. I have a great problem in defining solid-fluid interfaces that made me frustrated and I can't run CFX. I created new discussion about my current problem:


      https://forum.ansys.com/forums/topic/solid-fluid-interface-for-spheres/


      Thanks


       

    • DrAmine
      Ansys Employee

      Source is in W/m^3, Total source is in W (already integrated) 

    • rgfsteed
      Ansys Employee

      Hi Hamda,


      If the fluid and solid bodies are both included in your CAD model when you mesh it, the Workbench Meshing app will have identified these contacts and passed them on to CFX-Pre on import. Pre uses this information to create the default automatic interfaces. If you happen to manually define one of the interfaces or otherwise define a boundary condition on one of these faces, Pre will remove the corresponding regions from the automatic interface.


      If you have deleted the automatic interface, Pre won't regenerate it since the assumption is that you don't want it. To get it to regenerate the interface just visit the "General Options" under the case options at the bottom of the feature tree in Pre and re-enable "Automatic Default Interfaces".



      Regards,
      Robin

Viewing 4 reply threads
  • You must be logged in to reply to this topic.