3D Design

3D Design

SolidWorks to Ansys

    • Ulvi
      Subscriber

      I am trying to analyse weld toe stress in T joint made of circular hollow section ( pipe ). 3D Model is prepared in solidworks with solid elements and sweep feature. The weld profile edges are all consistent in solidworks however when I import the model with .iges into ansys and assign share topology it breaks all boundary edges. This creates difficulties with meshing the part. Can anyone please advise on what is the solution here? 


      Both solidworks native file and .iges attached


    • Aniket
      Ansys Employee

      Exporting CAD files to neutral file formats can lead to translational losses. Moreover, CAD software generally uses loose tolerances while creating the models as compared to the tolerances used by Mechanical. So something you see as coincident in CAD might not be actually coincident in Mechanical as you are seeing.


      Solutions can be as follows:


      1. Use tight tolerances in CAD. I do not know if it is possible for the specific CAD that you are using, but it is possible in some other CAD softwares


      2. Use native CAD file using CAD-Workbench connection instead of using a neutral file format such as iges step or Parasolid


      3. Use ANSYS tools such as DesignModeler or SpaceClaim to make the edges coincident


      4. You can also use Mesh connections in the Mechanical to connect the mesh nodes after generating the mesh using Mesh Edit tools


       


       

    • peteroznewman
      Subscriber

      Aniket's suggestion #3 was used with the SpaceClaim repair tools to repair some problems and to set Share Topology to Share.







      But even after that, I did not get a good mesh.  So I went back and Combined two solids, and deleted one face.



      Then I finally had a good geometry for meshing.


      Attached is the SpaceClaim 18.2 file.


       


       

    • Ulvi
      Subscriber

      Thanks for the response. I actually need those faces and splits but consistent to apply mesh controls. So I am actually looking for a solution that will not suppress any features of model 

    • Ulvi
      Subscriber

      Thanks for comments. What software packages are you referring? 

    • peteroznewman
      Subscriber

      That was SpaceClaim.

    • Ulvi
      Subscriber
      I modelled the structure in spaceclaim too but again whereever 3 and more boundaries come together on round surface it splits edges in multiple sub-edges
    • Ulvi
      Subscriber
      No solution???
    • peteroznewman
      Subscriber

      In SpaceClaim, I created two components, the Pipe and the Tee.  The Tee has two solids, the small pipe and the weld. The Pipe has two solids, the piece below the Tee and Weld and the rest of the pipe.  It looks promising in SpaceClaim...



      and here is the mesh with an element size of 3 mm.



      Slicing the bodies into smaller pieces may allow more hex elements in the mesh. Stay tuned.


      Attached is an ANSYS 18.2 archive.

    • peteroznewman
      Subscriber

      Hey, how about that!



      If your loading is symmetrical, you could use this model directly.


      ANSYS 18.2 archive attached.

    • Ulvi
      Subscriber

      Thanks Peter, Have you used chamfer option to model weld profile?

    • peteroznewman
      Subscriber

      No Ulvi, I just sliced off the chamfer you provided in the solid model that you made in Solidworks.

    • Ulvi
      Subscriber

      Thanks Peter, unfortunately I am using Ansys 17.2. Any chance that you can attach a compatible file?

    • peteroznewman
      Subscriber

      I had to redo the chamfer in NX and reduce the tolerances on the sweep I used to slice the geometry as suggested by Aniket.



      This was about 90 minutes of work to get to a successful mesh. 

    • Ulvi
      Subscriber

      make sense now. I actually spent quite a bit of time on this to get it work. What i did was a workaround. Put the splits not directly under the juction but a bit away and applied some meshing controls and worked.


      I appreciate the time that you have spent on it


Viewing 14 reply threads
  • You must be logged in to reply to this topic.