General Mechanical

General Mechanical

Solution branch delay

    • Costas
      Subscriber

      Hello and Happy New Year.

      I run a simple 2D axisymmetric model of a cylinder undergoing compression (both in static structural as well as in explicit dynamics). The solution process obviously depends on the mesh size (for example for a mesh with 20000 elements and 20000 nodes the solution takes around 1 hour, which I think is ok). However, when the solution has finished, and I want to see the results I experience the following problem. For meshes containing more than around 2000 elements and nodes (1000 elements and 1000 nodes) I experience delays when I navigate between different sub-branches in the Solution branch. For example, I am in the Model branch, and I want to go to Equivalent Stress (see image below) in the Solution branch. When I click on Equivalent Stress I need to wait for some seconds and even more for finer meshes (can reach 20 seconds delay) which makes it impractical to work (because I experience this delay for every action I need to do, for example to click on the tabular data, or copy/export the data etc.). This happens for every child in the Solution branch. When I return to a different branch (for example Explicit Dynamics, or Model) this problem does not exist. I tried to reduce the number of points in output controls, and this seems to help (for example I initially have 1000 points and I reduce to 100) but at the cost of not having the desired accuracy in my graphs.

      I experience this issue with two different versions in two different computers. I use the student version 2022R1 in my laptop (Intel i7-7500U CPU 2.70GHz, RAM 8GB, Graphics: NVIDIA GEFORCE GTX 1050), and I also use a full license version 2022R1 in my university computer (Intel i7-9700 CPU 3.00GHz, RAM 16GB, Graphics: Intel UHD Graphics 630).

      Is there anything I can do?

      Thank you,

      Costas

    • Ram Gopisetti
      Ansys Employee

      Hi, having the large result data set and loading it back into the interface do take the time to parse them into the result quantities, that delay is normal based on the hardware you had, to reduce the lag, you can delete the all the result and load the reuslt and then recreate it again, use an GPU  quilified for ANSYS to boost the perfrmance in loading the results 

      https://www.ansys.com/content/dam/it-solutions/platform-support/gpu-accelerator-capabilities-2022-r1.pdf

      cheers, Ram 

    • Costas
      Subscriber

      Hi Ram,

      many thanks for your answer.

      I tried to delete all results (I tried this suggestion first since changing/upgrading the GPU is quite costly and it will probably be a future step) and then create each one at a time, but it didn't help substantially.

      I tried the following and I would like your comment on this. I split the simulation in 4 time intervals (for example 0-0.0001s, 0.0001-0.0005s, 0.0005-0.001s, 0.001-0.002s) and I ran it progressively by using the "Resume from cycle" option in the Step Controls of Analysis Settings (so, I ran the first time interval, then I continue from the last cycle of the first time interval and so on). In this way I can set a higher number of results for the first part of the simulation which interests me more and finally I can have substantially less number of total result points. I think it works (at least so far).

      Regards,

      Costas

Viewing 2 reply threads
  • You must be logged in to reply to this topic.