Discovery Import

Discovery Import

SpaceClaim 2020 R1 unusable in case of a large model

    • thornyak
      Subscriber

      ūüõą This post originally contained file attachments which have been removed in compliance with the updated Ansys Learning Forum Terms & Conditions

      Hello!

       

      I can't do anything (Pan/Zoom/Rotate, selecting etc) on large models in Discovery SpaceClaim 2020 R1 because the screen freezes for seconds then continues. Imported STEP file size is ~25MB, saved SpaceClaim file size is ~59MB, the model consists of ~3000 bodies (see attached .rar file).

      Every time the screen freezes, the Power Usage column for SpaceClaim in the Task Manager is Very High, but the GPU% is around 0%, see first attached picture. Sometimes when I managed to Pan/Zoom/Rotate the model for a moment, then the GPU% increased above 50-80% besides Very High Power Usage, see second attached picture.

      In case of small models I experienced laggings/freezings too, but not so much as above mentioned. In an earlier SpaceClaim version small and big models are worked fine and smoothly.

       

      I tried to modify all kinds of graphics settings e.g: Rendering Quality, Anti-aliasing, OpenGL/Direct3D renderer, Shaded/Enhanced Shaded display settings etc. I tried to modify the NVIDIA driver settings as well. Among others, I tried the following recommendations as well but none of them helped:

      designspark(dot)zendesk(dot)com/hc/en-us/articles/360002322918-Is-DSM-slow-on-Windows-10-even-with-a-high-spec-machine

      help(dot)spaceclaim(dot)com/dsm/4.0/en/Content/Popular_options.htm

       

      Besides that in Discovery AIM 2020 R1, I experienced very slow and laggy Pan/Zoom/Rotate movement already on a small model when I selected "Enhanced display mode" but the screen did not freeze at least (as for SpaceClaim). But when I selected "Standard" or "Transculent" display mode, everything was fine and the model movement was smooth.

       

      Any ideas to fix these issues especially for SpaceClaim? Please recommend other graphics settings in SpaceClaim/AIM and in NVIDIA driver.

       

      My configuration:

      OS: Windows 10 Pro, Verision 20H2, Build 19042.964

      CPU: Dual Intel(R) Xeon(R) CPU E5-2680 0 @ 2.70GHz

      GPU: NVIDIA Quadro K5000 with up-to-date driver version (Version 466.11, Date 04.24.2021)

      RAM: 64GB

      SSD: Crucial MX300 2x525GB (RAID1)

       

      Thank you.

    • Charudatta Bandgar
      Subscriber

      Hello Tamas

      Let me look into this, I will get back to you.

      Regards.

    • Charudatta Bandgar
      Subscriber

      Hello Tamas

      There could be several reasons for the slowness, and looks like you have tried few things to sort it.

      Have you tried File -> Options -> Popular -> Rendering = 1? See if it helps. If that too doesnt help much, try internalising components and see if that helps (Source -> Internalize All). The slowness issue is improved in the upcoming release 2021R2, and there have been some improvements after 2020R1 as well, I would suggest you upgrade to the latest SC version 2021R1, and see if that helps. I will also try the files you shared on my end.

      Regards.

    • Charudatta Bandgar
      Subscriber

      Tamas  AIM has become a legacy product, post its last release in 2020R2.5, hence if you are using SpaceClaim with AIM, instead of upgrading to 2021R1 (as stated earlier download 2020R2), and see if it is better there. For slowness in AIM, since you are saying you are facing issues with simpler geometries as well,I will need to investigate further. 

      For Spaceclaim, maybe splitting the geometry in smaller components could also help, if it is feasible for you. 

      Regards.

    • thornyak
      Subscriber

      Charudatta Bandgar

      Unfortunately all of the folowings did not help:

      - decreased Rendering to 1 and disabled Anti-aliasing too

      - internalised all components 

      - splitting to smaller components

       

      Any other ideas?

      Have you opened the file? Have you experienced the same issues?

    • Charudatta Bandgar
      Subscriber

      Hello Tamas

      I tested in 2020R2 with the default graphics settings, and I did not face the issues you are facing, I think your issue could sort by upgrading to 2020R2 (or 2021R1 without AIM).

    • thornyak
      Subscriber

      Hello Charudatta Bandgar

      I think I managed to solve the problem. If I disable "constraint based sketching" on the Advanced tab, I can move/rotate the model relatively smooth. If I disable "beta features" as well, it seems that the model movement is even smoother and it's not annoying anymore.

      It is very strange, that the main reason was the activated constraint based sketching.

      Can you explain it to me please?

      Can you try to enable constraint based sketching in your SpaceClaim and rotatate/move my previously attached model? Have you experienced any problems now?

      Regards

      Tamas

      • Charudatta Bandgar
        Subscriber

        Hello Tamas 

        That is actually a strange behavior and I have not come across it, nor have other customers have highlighted it. I am glad that disabling constraint-based sketching solved your issue, but I will have to discuss with the developers to see if they are aware of any such issue and will try to understand it better. (PS. I was also using it with constraint-based sketching)

        Regards.

Viewing 6 reply threads
  • You must be logged in to reply to this topic.