Fluids

Fluids

Trouble modelling a 2D gear pump simulation using dynamic mesh in Ansys Fluent 19

    • Vivjk94
      Subscriber

      Hello, i am trying to perform a 2D gear pump simulation as part of my project. I have modelled a gear pump where the gear has 13 teeth and rotating at 2000 rpm. I have used water as the fluid and used a fine mesh with triangular elements. The pump inlet boundary condition has 0 Pascal and outlet has 2000 psi pressure. the udf code used is as follows:

      Rotating motion for gear 1

      #include "udf.h"

      DEFINE_CG_MOTION(gear_1_new,dt,vel,omega,time,dtime)

      {

      real t = CURRENT_TIME;

      NV_S (vel, = , 0.0);

      NV_S (omega, = , 0.0);

      omega[2] = -209.4395;

      }

      Rotating motion for gear 2

      #include "udf.h"

      DEFINE_CG_MOTION(gear_2_new,dt,vel,omega,time,dtime)

      {

      real t = CURRENT_TIME;

      NV_S (vel, = , 0.0);

      NV_S (omega, = , 0.0);

      omega[2] = 209.4395;

      }

      The dynamic mesh settings are as follows:

    • Rob
      Ansys Employee
      Chances are the gap between the teeth gets to be small and that's then skewing the mesh. There's been a lot of work on gears through the last couple of releases to resolve that problem and also the speed where we're spraying liquid around the gearbox. I don't have anything from our (technical) side to share, but check the Ansys blog posts as I think there was something published there.
    • Vivjk94
      Subscriber
      That figures. i had left almost 0 gap between the two gears. I will try with more gap.
      Thank you Vivek
    • Vivjk94
      Subscriber
      update- i gave about 1mm gap between the two gears and the simulation ran for a couple of timesteps which would never happened before in my old setup. I also find that reducing time step allows the simulation to run for a lot more time steps.
      Thank you Rob.
    • yeico01
      Subscriber
      I have the same problem, could you tell me how you solved it?
Viewing 4 reply threads
  • You must be logged in to reply to this topic.