Ansys Products

Ansys Products

Trying to run LS-Dyna on ubuntu 2020 system but getting an error

    • ldbuffalo
      Subscriber
      HellonTrying to run LS-Dyna on ubuntu 2020 system but getting an error:n *** Error 70004 (OTH+4)n invalid option on the command line:n DL_only_DR_run.kn E r r o r t e r m i n a t i o Please let me know what that error might be. Same input file worked on a different computer just fine.nThank you muchnLeon
    • tsiriaks
      Ansys Employee
      Hi Leo,nOn your another computer, is it also running Ubuntu 20.x ? Please provide exact OS version on both computers.nWhat is the LS-Dyna version you are using ? And what was the file name of the installation package that you used ?nThanks,nWinn
    • ldbuffalo
      Subscriber
      Hello, nI am sorry, correction one computer is at NAME=Linux MintnVERSION=19.2 (Tina)nThe second one is Ubuntu nVersion 20.04.1 LTS (Focal Fossa)nI used both nls-dyna_smp_d_R12_0_0_x64_redhat65_ifort160 and nls-dyna_smp_s_r1010_x64_redhat5_ifort160nThank younLeon
    • tsiriaks
      Ansys Employee
      Hi Leo,nI think this is LSTC LS-Dyna. I'm not familiar with this, I will have to ask others to help.nCan you provide the link where you get these installation packages from ?nThanks,nWinn
    • ldbuffalo
      Subscriber
      Win,nIt is, Sorry the link is password protected not sure if it is OK to put it in to the open forum like this. nThank you very much for trying to helpnLeo n
    • ldbuffalo
      Subscriber
      I am sorry but we have classes started and at this point I have few students and faculty who are not bale to use this software. ANY !!! help will be appreciated. Thank youn
    • Reno Genest
      Ansys Employee
      Hi Leo,nnThe error message tells us that something is wrong on the command line that you use to launch the run. Make sure you specify the input file as follow on the command line:ni=DL_only_DR_run.knCan you send me the complete command line you use to launch the run?.Thanks.nnReno.nn
    • ldbuffalo
      Subscriber
      rgbest, Thank you nI start with ./ls-dyna_smp_s_r1010_x64_redhat5_ifort160 and then input the input file nand then I get the errornThank you again nLeon
    • Reno Genest
      Ansys Employee
      Hi Leo,nI am running on Windows, but the command line on Linux is similar. It should look like this:nnC:\LS-DYNA\Dev_SMP_Double_Precision\ls-dyna_smp_d_Dev_78944_winx64_ifort170.exe i=\Support\Test\Test.k memory=20m ncpu=-1nnIt is better to specify the location of the LS-DYNA solver executable (ls-dyna_smp_s_r1010_x64_redhat5_ifort160.exe) and also the location of the input file (.k file).nnLet me know if it works or not.nnReno.nn
    • ldbuffalo
      Subscriber
      Reno,nnThank you will try, but it looks like there us an issue with the licenses. We are using a license server to control licenses and it looks like client system does not talk to the server nfew other systems work just fine with the method that I was using. Will update in few hours when I will try your recommendation, Thanks again for trying to help. much appreciated ...nLeon
    • Reno Genest
      Ansys Employee
      Hi Leo,nnLet me know how it goes. If it is a license issue, I can help you with that too.nnReno.n
    • ldbuffalo
      Subscriber
      Reno,nThank you, it is the license issue, I put the command exactly as you recommend and got the following errors:n*** License problem ***n Local license:n *** Error Bad license keys!n *** Error 70022 (OTH+22)n Please contactn Livermore Software Technology, LLCn Tel: 844.Go.Ansys (844.462.6797)n Email: LstSupport@ansys.comn E r r o r t e r m i n a t i o----nMind you we do not use local license but a network one.nThank younLeon
    • Reno Genest
      Ansys Employee
      Hi Leo,nnYou use a network license located on one server correct? If so, this is strange that you are able to run with some client machines and on others you get this error message. This error message tells us that your license file is not valid. You should be getting this error from any client machine. Have you modified the license file? Can you put the original license file back?.Also, make sure the client machines are pointing towards the license server. In other words, make sure you set the environment variables properly:nsetenv LSTC_?LI?CENSE net?worknsetenv LSTC_?LI?CENSE_?SERV?ER host_?or_?ipnhttp://www.lstc.com/download#section2nnLet me know how it goes.nnReno.n
    • ldbuffalo
      Subscriber
      Hello Reno, nLicense server has not been touched and it seem to work for other clients just fine. File was also not touched. And again for number of clients it works just fine.nI did the commands and the error remains :n please define input file names or change defaults :n >Dyna_model1.kn >Dyna_model1.knn *** Error 70004 (OTH+4)n invalid option on the command line:n Dyna_model1.kn E r r o r t e r m i n a t i oThank you for trying to help.nLeon
    • Reno Genest
      Ansys Employee
      Hi Leo,nnIf some client machines are not pointing correctly to the license server, then it will not work even if the license server is set up properly. Make sure the client machines are pointing to the correct license server.nAlso, can you send me the complete command line you used to get the following error?n *** Error 70004 (OTH+4)n invalid option on the command line:n Dyna_model1.kn E r r o r t e r m i n a t i o Thank you.nnReno.nn
    • ldbuffalo
      Subscriber
      Hello,./ls-dyna_smp_s_r1010_x64_redhat5_ifort160 Dyna_model1.knthe .k file runs just fine on a different computernThank you nLeon
    • Reno Genest
      Ansys Employee
      Hi Leo,nnYour command line is wrong; you need to put i= in front of the key file (.k) you want to run. For example:i=input.knThe command line should look like this on Linux:n/amddual_2/jensen/Executables/ls-dyna_smp_s_r1010_x64_redhat5_ifort160 i=input.knOr in your case:n./ls-dyna_smp_s_r1010_x64_redhat5_ifort160 i=Dyna_model1.knnLet me know how it goes.nnReno.
Viewing 16 reply threads
  • You must be logged in to reply to this topic.