Fluids

Fluids

UDS diffusivity

    • ChandulaW
      Subscriber

      Hi all,

      I am having some trouble defining the UDS diffusivity in the "change/edit materials" tab as it is not appearing. I have scoured the web to find a solution to no avail so I'm coming here as a last ditch attempt. Please let me know if there's something I'm doing wrong.

      Regards,

      Chan.

    • Karthik R
      Administrator
      Hello,nWhen you created your UDS, where did you assign the Solution Zone to? Did you activate at least one UDS (from User-Defined tab -> User - Defined ribbon -> Scalars)?nIf you have activated this, you should see the field UDS Diffusivity under material properties.nKarthik
    • ChandulaW
      Subscriber
      Hi Karthik,nOnce I activated one UDS, the UDS diffusivity still did not appear in the material properties dialog box. After going through the user defined database, I entered all of the other material properties for the cell area, but when adding the diffusivity, the uds-0 and uds-1 options did not appear under the coefficients tab as is shown in the screenshot. Is there something else I am missing?nThanks,nChan. nn
    • Rob
      Ansys Employee
      Did you set the scalar to work on fluids, solids or all zones? Default is fluid only. n
    • ChandulaW
      Subscriber
      Hi Rob,I set it to all zones and it still doesn't come up. I tried using the user defined database, and I was able to access the UDS diffusivity, however I am unable to input the coefficient values for uds-0 and uds-1 as is shown in the attached picture.n
    • Rob
      Ansys Employee
      It's working herennn
    • ChandulaW
      Subscriber
      I've tried it again by selecting all solid zones instead of all zones to see that I still can't access the UDS diffusivity. Could this error message have something to do with it by any chance?nn
    • Karthik R
      Administrator
      Hello, nIt is quite possible. Once you receive this error, you have to kill the existing Fluent session and launch a new one. When do you see this error message? Are you setting up your case from scratch or are you reading an already saved case into your Fluent session?nKarthikn
    • ChandulaW
      Subscriber
      Hi Karthik,nI've started over again and still get the same result. When I create a new material through the user defined setting and add the UDS diffusivity in, it comes as the electrical conductivity once I have the material. Can't understand why it's doing this. nThanks,nChan. n
    • Karthik R
      Administrator
      Hello,nFor starters: Could you please read just your mesh file, turn on 1 user defined scalar (keep settings to default), and look into the material property of 'air' and see if you are seeing the UDS Diffusivity option?nKarthikn
    • ChandulaW
      Subscriber
      Hi Karthik,nI did the process again and this time it worked initially and the UDS diffusivity appeared in the materials dialog box, however when I turned the battery model on, the option went away and I'm once again left with what's shown in the attached pictures. nRegards,nChan. nn
    • ChandulaW
      Subscriber
      Hi Karthik,nWith the same problem as before, I am also getting the following error message. Would you be able to shed some light on what this means?nThanks,nChan. nn
    • wcao
      Ansys Employee
      Hello,nIt seems like you have turned on the battery model, which will use 2 UDS for phi+ and phi- if it is two potential MSMD model. Starting from a battery model, if you need additional UDS, for example 2 other UDS, you will need to increase the total UDS number to 4 (2 of them already occupied by phi+ and phi-). Once more UDS has been allocated, you can find that the electrical conductivity properties in the material panel will show four items when selecting define-per-uds:nn
Viewing 13 reply threads
  • You must be logged in to reply to this topic.