Ansys Products

Ansys Products

Unable to load project in Ansys workbench/DesignXplorer

    • c.bruno
      Subscriber

      Hello everyone,

      I have been working with Ansys DesignXplorer for the past week but now when I try to open my workbenck file I get this error:

      Everything started when I added a new Response Surface Optimization block and I tried to share data with an old one:

      Does anybody know how to solve this? I checked the simulation's folder and it seems alright, but still I can't open any of the simulations that I run on this file.

      Thank you!

    • Aniket
      Ansys Employee

      System H, which has the black Cross mark, shows an indication of Corruption, you may have to delete the system, and reinsert it again.

      -Aniket

      How to access Ansys help links

      Guidelines for Posting on Ansys Learning Forum

      • c.bruno
        Subscriber

        Hi Aniket,

        Thank you for your reply. I tried to delete system H but I get this error:

        Is there another way to remove it and restore my workbench?

        Thank you

    • Aniket
      Ansys Employee

      This is an indication that something corrupt has occurred to the cell in that project and is often due to certain other connecting parts being deleted previously. When clicking on the cell entry you get a number of error messages that appear like:

      ”This reference to container Geometry is not valid for use with this project”.

      To be able to remove this cell follow these steps:
      1) Select the system that contains the bad cell, RMB > Properties, and find the “System ID”. For example, it could be “Geometry”, Here it most likely would RSO or RSO 1 or RSO 2
      2) In Workbench go to File\Scripting\Open Command Window.
      3) In the Window that opens type:


      badSystem = Project.GetSystem(“RSO 2”) # NB. Substitute your own System ID instead of *RSO 2*
      badSystem.Components = []

      4) You can now close the Command Window and should be able to delete the corrupted system

      -Aniket

      How to access Ansys help links

      Guidelines for Posting on Ansys Learning Forum

       

       

    • c.bruno
      Subscriber

      Thank you very much Aniket, it worked.

      I have removed the corrupted system and now I would like to load my project back. Is there a way to load the results of my simulations back to the workbench?

      My systems that were uncorrupted look like this, they are completely empty:

      I still get this error, but I didn't make any change on the folder of the simulations so I am not sure why Ansys can't find it:

      Thank you very much!

Viewing 3 reply threads
  • You must be logged in to reply to this topic.