3D Design

3D Design

Unable to simulate snap fit part 2.

    • juhuang7
      Subscriber

      I wasn't sure if I should start a new post or continue this discussion but I'm having the same issue again with a different snap-fit. I've tried moving the part until it just touches the contact but I'm still experiencing the 'inactive' status. As a result, it's not detecting the contact between the 2 parts. I've attached my archived project here. Here are some pictures of my contacts and settings.


    • peteroznewman
      Subscriber

      I recommend putting a small radius on the tip of the snap that has the 45 degree sharp point and the same small radius on the 90 degree corner at the bottom of the lines in blue if you want to simulate the snap going around the corner.


      Don't put any edges in the contact set that will never make contact such as the left and bottom red edges.


      Finally, increase the pinball radius until you get closure.


      It is better to start a New Discussion once you mark an old discussion with Is Solution. Also, shorter discussions are easier to read than long ones.

    • juhuang7
      Subscriber

      Hi Peter, thanks for the recommendation.


      No matter how big I make the pinball radius, the status keeps appearing as 'near open'. I'm not sure what to do from here. On another note. I keep receiving the following messages when I run my simulations:


      - One or more objects may have lost some scoping attachments during the geometry update. You can identify these tree objects by filtering the tree using the Scoping option set to Partial.


      - One or more bodies may be underconstrained and experiencing rigid body motion. Weak springs have been added to attain a solution.  Refer to Troubleshooting in the Help System for more details.


      - Contact status has experienced an abrupt change.  Check results carefully for possible contact separation.

    • peteroznewman
      Subscriber

      I just noticed the link to your project in your original post.


      1) The two parts should be tangent. They are not. I moved them to be tangent and added the radius fillets recommended above.



      2) You should do this as a 2D Plane Strain model. That requires the geometry to be in the XY plane, so I used SpaceClaim to move the surfaces to Z=0.



      3) Change the 2D behavior to Plane Strain.



      4) I only included the needed edges in the contact definition. I set the Normal Stiffness to a Factor of 0.1 which means a little more penetration in exchange for an easier contact convergence.


      5) I added keyopt(6)=1 to the elements for mixed u-P formulation, which helps convergence in high pressure situations like the tip of the snap.



      ANSYS 2020 R1 archive attached.

    • juhuang7
      Subscriber

      Hi Peter, thanks for replying.

      In which setting can I add 'keyopt(6)=1'?

    • peteroznewman
      Subscriber

      Look under the Geometry category, under each surface body, there is a Command Object.

Viewing 5 reply threads
  • You must be logged in to reply to this topic.