Ansys Products

Ansys Products

Unable to start the geometry editor. Linux

    • andygav
      Subscriber

      Hi, I have a Dell R720 server running RHEL 8.5 with Ansys 2021R2

      This has the standard Matrox graphics card on the m/b but has a Tesla K40c GPU. I connect to it using Xming from a PC with a Quadro card in it.

      Issue with trying to edit the Geometry. Unable to start.

      GLXgears runs OK. Ansys WB starts up OK. Fluent starts OK and can see the GPU. It does report "Direct rendering unavailable, hardware acceleration will be disabled." which is fair enough.

      Relevant output from lspci is

      05:00.0 3D controller: NVIDIA Corporation GK180GL [Tesla K40c] (rev a1)

      0b:00.0 VGA compatible controller: Matrox Electronics Systems Ltd. G200eR2

      And

       lspci -nnk | grep -i vga -A3 | grep 'in use'

          Kernel driver in use: mgag200

      glxinfo | grep -i "opengl renderer"

      OpenGL renderer string: Software Rasterizer

      Running the CUDA samples finds the GPU ok. This driver is at the 460.106.00 revision.

      Tried using the mesa drivers in the Ansys directories.

      Any way of getting this to work?

      I suspect if the Geometry editor is trying to use an OpenGL card on the system then the Matrox card won't do this and the K40 running in TCC mode won't do it either. I was hoping it could be used for frame buffering. I'm going to fit another Quadro card in it to see if this makes a difference when I get the chance. Obvs, I won't be connecting a monitor to it..

      Andrew

    • Rob
      Ansys Employee
      Which geometry tool? SpaceClaim does not work on Linux, DesignModeler does.
    • andygav
      Subscriber
      Hi Rob. Its using DesignModeler.
    • Rob
      Ansys Employee
      Looking at the system we only support up to 8.4 https://www.ansys.com/content/dam/it-solutions/platform-support/platform-support-by-application-product-2022-r1.pdf so you might be missing something. will know more.
    • George Karnos
      Ansys Employee

      I believe your assumptions are correct.
      The Matrox card will not suffice.
      From what I read...TCC mode does not provide CUDAÔÇôDirectX/OpenGL interoperability.
      It is a ÔÇ£non-displayÔÇØ driver, and NVIDIA GPUs using this driver will not support
      DirectX or OpenGL hardware acceleration
    • andygav
      Subscriber
      Some success.
      I loaded up Rocky8.5 on a Hyper-V VM and tried ssh -X to the server
      That displays the geometry editor OK. The machine its running on is win10, 8 years old and has an integrated graphics card. Installed Rocky8.5 natively on a similar vintage PC and thats OK too.
      Thinking that Xming, might be to blame here or rather my use of it, installed VcxSrv and that worked straight out of the box. Tried setting the various options such as Native OpenGL on a PC with/without a supported card and connecting to a machine running Ansys with/without a supported card and LIBGL_ALWAYS_INDIRECT=1 or 0 with no perceivable change in performance although I think in each case its using the software rasterizer.
      I try and do some further testing in a week or two and report any findings.

    • andygav
      Subscriber
      Done some more testing on this.
      My machine has a Quadro P4000 used in TCC mode (so it doesn't have a monitor attached to it) and a Quadro K620 used to drive the display.
      Running glxinfo was showing this card as being the renderer, although I was getting a display through the K620. In order to force it to use the K620, I removed the P4000.
      Anyway here is my findings. Written in bold is whether the DesignModeller (DM) started up OK. OpenGL ticked/not ticked is on the VcXsrv launch page.
      I've run out of expertise and time but one other thing I noticed was it didn't work at all over a GlobalProtect VPN. The Workbench opened in all cases.





Viewing 6 reply threads
  • You must be logged in to reply to this topic.