Ansys Products

Ansys Products

Unable to start the Meshing editor – Linux (RHEL 7.5) VNC VirtualGL

    • db_ik
      Subscriber
    • Matt Madore
      Ansys Employee
      ArrayWhat happens if you start Workbench using vglrun wb202 or vglrun wb211.nWhat do you have for graphics devices on the local and remote machines?n
    • db_ik
      Subscriber
      Hi, thank you for your replynthe command with n$ vglrun /ansys_inc/v211/Framework/bin/Linux64/runwb2 nshows the error as unable to start the meshing editor.nit works for Ansys 2020 R1 but after version 2020 R2 & 2021R1 show the error of unable to start the meshing editor.nFluent and design modeler are working find for all version, but for not the mesher.nI attached the glxinfo, you can see the graphics optionn(it has Nvidia Quardo K2000 - installed the most updated driver from Nvidia)nat front of the workstation desk, all version works fine however, remote access is the issue though version 2020R1 works all fine.nCould you please have a look why the version 2020R2 and 2021R1 are not working...nMany thank you,n
    • Matt Madore
      Ansys Employee
      Can you run these commands and send the output?.cat /etc/*releasenglxinfo -display :0 | grep -i opengl.versionnLIBGL_DEBUG=verbose glxgearsnLIBGL_DEBUG=verbose glxinfonlspci -vnn | grep VGA -A 12nnvidia-sminnvidia-settings -q NvidiaDriverVersionnnvidia-settings -q allnn
    • db_ik
      Subscriber
      Thank you for your help!nplease find attached files for the informationnn
    • Matt Madore
      Ansys Employee
      if you open a command prompt and run 'ping localhost' can you share the output?n
    • db_ik
      Subscriber
      Thank you for your prompt message, please see below information for 'ping localhost'n$ ping localhostnPING localhost (127.0.0.1) 56(84) bytes of data.n64 bytes from localhost (127.0.0.1): icmp_seq=1 ttl=64 time=0.056 msn64 bytes from localhost (127.0.0.1): icmp_seq=2 ttl=64 time=0.030 msn64 bytes from localhost (127.0.0.1): icmp_seq=3 ttl=64 time=0.019 msn64 bytes from localhost (127.0.0.1): icmp_seq=4 ttl=64 time=0.024 msn64 bytes from localhost (127.0.0.1): icmp_seq=5 ttl=64 time=0.024 msn^Cn--- localhost ping statistics ---n5 packets transmitted, 5 received, 0% packet loss, time 3999msnrtt min/avg/max/mdev = 0.019/0.030/0.056/0.014 msn
    • Matt Madore
      Ansys Employee
      Array RH 7.5 is not supported for ANSYS 2021 R1. When you installed 2021 R1 it may have changed something in the ANSYS files that is affecting ANSYS 2020 R2. It's most likely related to the libs since it mentions libstdc++.so.6.nThe LD_LIBRARY_PATH=/ansys_inc/v211/Framework/bin/Linux64/Mesa#export is set to 2021 R1. Can you delete this or set to the 2020 R2 and see if this resolves the problem for 2020 R2 since it is supported under this OS and, if so, you will not be able to run 2021 R1 on this machine without updating the OS. n
    • db_ik
      Subscriber
      Thank you for your comment, I applied as you recommanded but the version 2020R2 is also not working.nAt the physical workstation location, all versions are working okay, but remote access causes the issue.non another machine, fresh restarted the OS and cleared the caches by deleting .ansysnit starts the mesh editor ONLY ONE TIME with following statement as[Info] Server started at ws://0.0.0.0:0 (actual port 44911)nHowever, fails to start the mesh editor no the next opening mesh.nRegards,
    • Matt Madore
      Ansys Employee
      What is the version of VNC you're using? Are you using VNC Connect 6.7.2 and VirtualGL 2.6?nhttps://www.ansys.com/-/media/ansys/corporate/files/pdf/solutions/it-professionals/platform-support/remote-display-and-virtual-desktop-support-2021-r1.pdf?la=en&hash=A0A10CB1AD545ACBEC69B57DCE129E5540E7E63Cnn
    • db_ik
      Subscriber
      It is now updated RHEL 7.5 to 7.7 remotely.nIt is using TigerVNC server, not Real VNC.nAfter the update of RHEL, the design modeller and mesher can not start and error message is;n[VGL] ERROR:Could not open display :1.0.n   Error:SERVER TO CLIENT CONNECTION ERROR:Connection to WB failed:System.ArgumentException: Invalid port number 0 upon calling CreatePortBasedURIn at Ans.IPC.Remoting.Common.Connection.CreatePortBasedURI (System.Int32 portNumber, System.Type requestedType) [0x00023] in <46baf23f153a45738c126797ab4c5b9b>:0 n at Ans.IPC.Remoting.Server.ServerToClientConnection.InitialConnect (System.Type classToProxy) [0x00000] in <46baf23f153a45738c126797ab4c5b9b>:0 n at Ans.IPC.Remoting.Server.ServerToClientConnection.TryToConnect () [0x00000] in <46baf23f153a45738c126797ab4c5b9b>:0for the display, vglrun -d:1.0 glxgears is perfactly working and run ansys as vglrun -d :1.0 wb211 showed above error.n
Viewing 10 reply threads
  • You must be logged in to reply to this topic.