General Mechanical

General Mechanical

Undefined line 1

    • joepa_2017
      Subscriber

      I have been working on meshing a complicated 2d geometry in APDL.  I import the geometry from an IGES file, and as I troubleshoot the mesh, I simply copy and paste the code from a text file.


      One of the times that I tried pasting the code in the command line, I got an error that said "Undefined line 1".  When I close that window, another error pops up saying, "Undefined line 2", and this goes on for several more lines.  I have also noticed that when I show the line numbers on the plot, the lowest line number is 14 instead of 1 now.


      I have restarted ANSYS multiple times and have even restarted my computer.  I don't know how this issue could have started, and I don't see a way to fix it either.  I appreciate any suggestions.

    • Aniket
      Ansys Employee

      Hi joepa_2017,


      Can you please explain what you mean by "troubleshooting" mesh? Are you creating the new mesh on the imported iges geometry? Also, what is the code you are copy pasting? It may be possible that you are selecting some component selection methods and those components are not defined in your model yet.


      This is certainly not a session issue which restart would fix.


       

    • joepa_2017
      Subscriber

      I have a complex 2d geometry, so it's been a bit difficult to get a mesh to work without errors occurring.  So, by troubleshooting the mesh, I just mean that I'm trying to refine the mesh in a way that the geometry can be meshed and then used for a solution that converges.


      Yes, I'm meshing an imported iges geometry.  I save the commands I write in a text file; that is the code that I paste into the command prompt in APDL.


      I was able to get around the issue by re-importing the iges geometry and then pasting the rest of the commands in the command prompt, rather than using the same "code" that had been importing the iges file.

    • Bhargava Sista
      Ansys Employee

      Sounds like the lines that you use for importing the file are incorrect, it would help if you can share those lines from the snippet that you're using. As Aniket said, this may not be an issue with the system or installation so restarting would not help.

Viewing 3 reply threads
  • You must be logged in to reply to this topic.