Preprocessing

Preprocessing

unexpected elements shape in fluid domain meshing for Fluent

    • ak_thawait
      Subscriber

      Hi, I am trying to create structured mesh in Workbench meshing using multizone method for a flow domain around 3D finite swept back wing. Mesh is generated successfully without any error, but I am getting unexpected element shape near the trailing edge. If I reduce element thickness near the surface of the wing by inflation or by very high biasing to get desired Y+ value, it results negative cell volume. If someone can tell me the reason for this and how can I overcome this problem it will be very helpful.

      Thank You.

      Amit

    • Keyur Kanade
      Ansys Employee
      Looks only 5 divisions at that locations. Can you please increase no. of divisions and check. nRegards,nKeyurnHow to access Ansys Online Help DocumentnHow to show full resolution imagenGuidelines on the Student CommunitynHow to use Google to search within Ansys Student Communityn
    • ak_thawait
      Subscriber
      Thanks Keyur for your reply. Actually when I am increasing the no. of elements, more no. of elements are becoming of negative volume. so less no of division is improving the cell quality. nThanks and RegardsnAmitn
    • Keyur Kanade
      Ansys Employee
      Can you split that face as belownn
    • ak_thawait
      Subscriber
      Thanks for the suggestion. Let me try this also.nI think the problem is because of very small radius of curvature. the chord and span of the wing are 1.833 ft and 2.5 ft respectively while radius of curvature is 0.0001 ft at the trailing edge. But when I increased radius of curvature to 0.0005, I am not getting such problem. So is this problem is faced generally when there is such large difference in dimensions are present?nAlso when I used 0.0005 radius of curvature, the negative cell volume problem is resolved, but I am getting another error while transferring mesh to Fluent. The error msg is The mesh file exporter failed during translation. Please send your data to your support provider.nThanks and regards,nAmitn
    • Keyur Kanade
      Ansys Employee
      If negative elements, it may give error in export. Also please cross check your named selection. n
    • ak_thawait
      Subscriber
      Thank you very much. Yes there were some negative elements, because of which getting error on export.n
    • ak_thawait
      Subscriber
      Also I tried your suggestion of dividing the faces but still it is not working and getting same problem for each divided segments. By some trial and error I came to know that when the first layer height is large, there is no such problem. But as I start decreasing the first layer height, the distortion starts appearing after some thickness. n Also I am using very high bias factor 15000 in edge sizing instead of inflation layer. Can this be the reason for such problem?.
    • Keyur Kanade
      Ansys Employee
      Yes, it could be the reason. Please try to split the faces and use different sizes. You can also check virtual topology in meshing. You can convert only that face to VT and proceed. nn
    • ak_thawait
      Subscriber
      Ok. Let me try these. Thank you very much..n
Viewing 9 reply threads
  • You must be logged in to reply to this topic.