Electronics

Electronics

User Defined Model (UDM) can not simulate in HFSS 18

    • Leo_UCDavis
      Subscriber

      I was redirected from the old support portal. Posting the same question here. The original SR# is 1794782461.


      ===


       


      Update:



      • This seems to be an issue with the 18 version. The original OnDieSprialInductor UDM runs well in HFSS 15, but not in 18.


       


      ===


      Hi 


      I was trying the OnDieSpiralInductor  UDM that shipped with HFSS. I can add the model and change its parameters with no problem. However, when I try to simulate the setup, I get the following error. 


       


      "


        HFSSDesign1 (DrivenModal)


          [error] Objects "ILD" and "Inductor" intersect. (2:584 PM  Aug 13, 2018)



       


      Obviously this is due to the ILD and Inductor intersecting each other. This seems to be a problem with UDM script. For the sake of demonstrating the simulation problem, I removed the creation of the ILD from the UDM script and saved it as a new UDM with the name "Inductor". 


       


      After setting up everything correctly and passing the green "Validate" check, HFSS gives the following messages before halting the simulation. 


       


      *Global - Messages


        [info] Window "Project4 - HFSSDesign2 - Modeler" has been closed to avoid display Instability  Please reopen


      Project4 (DScratch/Ansys/)


        HFSSDesign2 (DrivenModal)


          [error] Failed to refresh submodel Inductor1 (3:21:59 PM  Aug 13, 2018)


          [error] Body could not be created for part Port1 because of invalid parameters of this part or some of its parent part/coordinate system. (3:21:59 PM  Aug 13, 2018)


          [error] Body could not be created for part Port2 because of invalid parameters of this part or some of its parent part/coordinate system. (3:21:59 PM  Aug 13, 2018)


          [error] Body could not be created for part Inductor because of invalid parameters of this part or some of its parent part/coordinate system. (3:21:59 PM  Aug 13, 2018)


          [error] Body could not be created for part Via1 because of invalid parameters of this part or some of its parent part/coordinate system. (3:21:59 PM  Aug 13, 2018)


          [error] Body could not be created for part Via2 because of invalid parameters of this part or some of its parent part/coordinate system. (3:21:59 PM  Aug 13, 2018)


          [error] Body could not be created for part Underpass because of invalid parameters of this part or some of its parent part/coordinate system. (3:21:59 PM  Aug 13, 2018)


          [error] Body could not be created for part Inductorfeed1 because of invalid parameters of this part or some of its parent part/coordinate system. (3:21:59 PM  Aug 13, 2018)


          [error] Body could not be created for part Inductorfeed2 because of invalid parameters of this part or some of its parent part/coordinate system. (3:21:59 PM  Aug 13, 2018)


          [error] Port '1': Both endpoints of port lines must lie on the port. (3:21:59 PM  Aug 13, 2018)


          [error] Port '1': Length of port lines must be greater than zero. (3:21:59 PM  Aug 13, 2018)


          [error] Port '2': Both endpoints of port lines must lie on the port. (3:22:00 PM  Aug 13, 2018)


          [error] Port '2': Length of port lines must be greater than zero. (3:22:00 PM  Aug 13, 2018)


          [error] Simulation completed with execution error on server: Local Machine. (3:22:00 PM  Aug 13, 2018)


       


       

    • Leo_UCDavis
      Subscriber

      bump

Viewing 1 reply thread
  • You must be logged in to reply to this topic.