General Mechanical

General Mechanical

Virtual Topology + Bearing Load = Not possible?

    • albin.linderstam
      Subscriber

      Hello,

      All the holes of the 3D-model are divided into two surfaces when importing the model, so I tried to simplify the mesh by combining surfaces of holes using Virtual Topology.

      It seemed to work great and the mesh looked better. However, I could not use the Bearing Load to this combined surface. It was possible to apply different constraints to these surfaces, but not Bearing Load.

      Whenever I tried to select the surfaces and pressed OK, it told me to select surfaces once again, and again,...

      So I had to remove the Virtual Topology to Apply the Bearing Load.

      Do anyone know why this is the case?

      Since the "hole surface" is splitted into two halves automatically when I import the model (CatPart), the mesh does not look perfect at the location where these two halves meet, hence why I wanted to use Virtual Topology.

      Regards, Albin

    • peteroznewman
      Subscriber
      I always open geometry in SpaceClaim and use the tools on the Repair tab called Extra Edges and Split Edges to remove both of these. That will automatically replace each split hole with a single cylindrical surface with an unsplit edge on each end. Once you do that, Bearing Loads will work properly.
      If you are using a direct CAD interface and want to parametrically update geometry from CAD, then you can't do what I described above.

    • albin.linderstam
      Subscriber
      Thank you for your answer!
    • albin.linderstam
      Subscriber
      from your answer, is there any reason to use Virtual Topology? Since it can be solved in SpaceClaim without having issues applying loads.
    • peteroznewman
      Subscriber
      First choice is fix things in SpaceClaim.
      Virtual Topology is often useful and doesn't cause problems, and it can save the time compared with going out to SpaceClaim and back.
    • albin.linderstam
      Subscriber
      When I tried to open the model in SpaceClaim, the edges in the holes weren't there, so I could not merge the surfaces.
    • peteroznewman
      Subscriber
      Maybe you have the checkbox ticked that says to Improve Geometry on Import. That would do it automatically for you.
    • albin.linderstam
      Subscriber
      You are correct. Thank you.
      When I loaded the geometry in SpaceClaim, saved it and imported it to Ansys, I received the following messages:
      Is this something that I need to change? I went back to SpaceClaim and changed to "mm", same as in mechanical.
      The other message, is that simply due to improves geometries?
    • peteroznewman
      Subscriber
      The length unit change is a one-time warning, so after you check your model, you won't see that next time you open SpaceClaim and update the model with revised geometry.
Viewing 8 reply threads
  • You must be logged in to reply to this topic.