Ansys Products

Ansys Products

Discuss installation & licensing of our Ansys Teaching and Research products

what port range to open for full RSM communication?


    • Steve Jailall

      we have a RSM box on campus. I am remote, troubleshooting the RSM Config utility. When trying to send a test job, I seem to get errors with random ports, example:

      Remote service JobManagementService at ansys-rsm[]:29614 not reached.

      A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond

      Our Network team has been helpful in opening ports to try and get this to work. So far we have opened: 9195, 11195, 12195, 13195, 9231, 29263.

      This support link looks relevant, but I added a port to the portrange line with the same issue resulting. RSM failed to verify my credintials when connecting to the cluster (

      Rthe RSM is setup as HPC type: ARC, windows x64

      RSM internal file transfer mechanism selected




    • VJ
      Ansys Employee

      Hello Steve, once the changes have been made to the rsm config file on the head node, the RSM Launcher service needs to be restarted from the Services window for the changes to take effect.

      What is the port range that you fixed? Was the same range also opened in the FW rules on the workstations and headnode?

    • Steve Jailall

      Hey VJ. Here is what is in the config file:




    • Steve Jailall

      The port ranges didnt post, here they are. but yes these are open on the network 

      add key="PortRange" value="4000-4020" /
      add key="SocketTransfererListenerTimeoutMilliseconds" value="30000" /
      add key="SocketTransfererReceiveTimeoutMilliseconds" value="30000" /
      add key="SocketTransfererSendTimeoutMilliseconds" value="60000" />
      add key="SocketTransfererAbandonedSocketCleanupPeriodMilliseconds" value="30000" /
      add key="SocketTransfererAbandonedSocketMilliseconds" value="10000" /
      add key="SocketTransferServerKeepAliveMilliseconds" value="30000" /
      add key="SocketUseNagleAlgorithm" value="true" /
      add key="SocketSetFileSizeUpFront" value="true" /
      add key="SocketTransfererUseIPv6" value="false" /

              Default ports are usually greater than 50000.  This option may be required
              for environments where upper port range is restrictioned by firewall.  e.g. "1000-2000"
      add key="SocketTransfererPortRange" value="1000-29263" /
              This setting may be required if the server side has multiple network interfaces. e.g ""

    • VJ
      Ansys Employee

      can you also check if the "Port Range" value under UserProxy is sent to the same range value?

      Also, you opened a range from 1000-29263. This means, the Inbound rule should be opened for the entire range. I only see 29263 in the opened list of ports.

Viewing 4 reply threads
  • You must be logged in to reply to this topic.