Preprocessing

Preprocessing

why am I receiving a warning “Specified displacements from the previous D command…”?

Tagged: 

    • safiana
      Subscriber

      Hi everyone,

      I am modeling a 3D model solved by transient analysis. For the boundary conditions of my model, I have selected nodes attached to several surfaces by following commands:

      asel,s,loc,-10

      nsla,s

      lsla,s

      ksll,s

      nsll,a

      nslk,a

      D,all,uz,0

      D,all,volt,0

      allsel


      So, I did the same thing to select nodes for a few other surfaces and applied my constraints. For 2 nodes, I also used the command D,Node_1,ux,0. In total, all my boundary conditions were defined by D command for specified nodes.

      When I run my simulation, for each time increment, there are too many warnings as below, before solving each time increment:

    • 1shan
      Ansys Employee
      Could you issue the command /NERR,-1 . This will direct the solver to write only 1 warning message per command to the error file.
      Regards Ishan.
    • safiana
      Subscriber
      Thank you very much, Ishan. I just tried it and unfortunately, it didn't work. It is constantly showing this message on the APDL output window, GUI, and error file.
      I really don't understand what it means by "specified displacement from the previous command D...". Even if I run my simulation for 2 times step, again hundreds of times this warning must be shown first before going to the solution. I don't have this D command in a loop.

      Thank you!

    • 1shan
      Ansys Employee
      Looks like you are missing the 'component' of asel command - asel,s,loc,y,-10
      Regards.
      Ishan.
    • safiana
      Subscriber
      Sorry about this typing mistake here. In my code, the command was correct but here I missed "Y".

      Thank you Ali
Viewing 4 reply threads
  • You must be logged in to reply to this topic.