Topics relate to HFSS, Maxwell, SIwave, Icepak, Electronics Enterprise and more

Why do all the results of my simulations come up as NaN?

    • byeongwoo yoo

      Hi, I'm using Maxwell 3D to test my WPT system.

      but, all simulation results are NaN

      I checked the validation and it showed up correctly, 

      and progress log said ther were solved.


      I set up simulation based on Matrix, and set up the [analysis] as shown below.

      In fact, the first time I tried it, it simulated successfully, but after changing the size of the coil and trying it over 10 times, It just keeps coming up NaN.


      The weird thing here is that when I load the system component model, it used to load in past, but now it fails with the message below.

      Could this be the reason why the simulation is not working?


      I've tried deleting and reinstalling, but the result is the same.

      How can I get the results for simulation?

      Please help me





    • Ivonne Marti
      Ansys Employee

      Hello byeongwoo yoo,

      Here we have 2 issues:

      1/ no results when you compute the Coupling Coef.

      2/ an error message when you import a 3D Component model.

      I would start fixing issue number 2, since it could be related to issue number 1. The error message about the 3D component is very clear, you should use Eddy Current or Transient solver.

      Looks like you are using the Magnetostatic solver. This solver only considers DC currents. If you are designing a WPT system, I would suggest using Eddy Current or Transient solver to capture the eddy currents on the metal sheet. Probably the usage of one of these solvers will also help to fix issue number 1.

      I hope this helps. Ivonne

      • byeongwoo yoo

        Hello Ivonne Marti,

        Thank you for your reply.


        I looked at the simulation logs and realized that the issue was in the mesh size limitiation.

        Is there any way to reduce the mesh size?


        I tried set the initial mesh settings.

        Moreover, set the element length based refinement tab as shown below.

        But mesh size had not reduceed any value(71000 over).

        How can I reduce mesh size?


        Thank you,

        Byeongwoo yoo


Viewing 1 reply thread
  • You must be logged in to reply to this topic.