Ansys Products

Ansys Products

Workbench 18.2 Fatal error-Framework error

    • panther_91
      Subscriber

      Hello!


      I got the following problem, when I try to open the workbench : "Framework error caught:


      Fatal error:The view "GraphScene" has not been registered", as you can see on the attached picture.


      I repeated the installation and tried on 2 computers, but got the same result.


      Could anybody help me to solve this?


      Thanks in advance!

    • designer9595
      Subscriber

      Hi 


      I've same problem.I have student version 18.2 but ? can't solved this problem.Can you help me ?


      Thank you

    • pgl
      Ansys Employee

      OK. After looking around on the web I found that general OS "error" site also had a few people with this problem. I was surprised to find this, but thought I'd share to see if this helps you: 


      One of the posters states that "this error is usually caused by misconfigured system files....So, from my experience, if you received a Framework Error Caught ANSYS Workbench message then there is a 95% chance that your computer has registry problems..." 


      There's quite a few freewhere/shareware tools out there that can help you clean up registry issues. I personally use CCleaner, but there are many others. Here's a good review from Tech Radar. 


      So, use one of the mentioned tools to clean up your Windows registry, then reboot and launch ANSYS Workbench. Report back here if you have success.   


       


       


       

    • Loïc
      Subscriber

      Hi !


      I cleaned up my Windows registry with CCleaner, I rebooted and launched ANSYS Workbench but the same error message... I have even downloaded a new setup after that and cleaned up again but it did nothing. Have you another idea ?


      Thanks

    • IngAEV
      Subscriber

      I have done the registry cleanup aswell, and it doesn't work. The error keeps appearing. Help! I'm so behind on my homework u.u 

    • Vishal Ganore
      Ansys Employee

      This can occur if a C++/.net redistributable Ansys-prerequisite is not installed.

      Missing MS VC++ 2012 Redistributable x64

    • IngAEV
      Subscriber

      Thank you for answering, unfortunately it didn't work. The same error pops up. 

    • clsmyr
      Subscriber

      I am having same error on Windows 10 64 bit.


      Damn, i can not do my homework.

    • joaodaniel
      Subscriber

      I had the same problem that you had and, fortunately, I found a solution. I hope it works with you too.


      The problem was in the name of my user account. My name is a double name, so my user account has a space and, in addition, an accent as well. Ansys doesn't know how to read any of this characters. So, when it's searching for an archive necessary to open the program, it crash. It's like a bug or something, I don't know for sure. The fact is that Ansys doesn't know how to read strange characters in the names of the folders in which it is installed.


      The solution was to uninstall the program, create a new user account (with letters and nothing more) and then reinstall it. Worked perfectly here.

    • pgl
      Ansys Employee
    • sohrab sardari
      Subscriber

      I had the same problem as yours, and that didn't get solved by changing the username of PC. the solution is very very simple:


       


      The letters of the path of the ansys project file in your drivers should be only in english alphabet, a b c ... z, For example : "Cprojects/heat/heat_transfer.wbpj"


       

    • birinci
      Subscriber

      Hi,


      I am not using student version but ? have the same error, you can look the jpeg. Also I checked the setup path and there is no special character, I am using windows 7 so ? guess this is not OS error what should I do? please help


       


    • birinci
      Subscriber

      I solved the problem, actually problem was about setup folder, I download the 18.2 from ansys official website and now it is working.


      thanks anyway 

    • rishikesh
      Subscriber
      Did your problem solved?
      Fatal error problem!
      If solved, please tell me how?
    • rishikesh
      Subscriber
      Did your problem solved?
      Fatal error problem while running workbench!
      If solved, please tell me how.
    • Trouyan2
      Subscriber

      Good afternoon.


      I've some error at start workbench =(


      I have't special character in PC name, user namea and install path.


      I've used CCleaner in order to clean register.


      Used administration right,


      Tried launch with compatibility with different windows version.


      And tried to reinstall Ansys (install was done without any problems)


      Checked Windows with sfc /scannow


      Nothing help me =(


      First error:


      Failed to load addin Ans.TabularData.TabularDataAddin from ...



       


      Second:


       


      Failed to load addin Ansys.CFX.CFXCoreAddin from ...



       


      Third


      Failed to load addin Ansys.Fluent.Addin from ....



       


      Last


      Failed to load addin Ansys.EngineeringData.Commands.Addin from ....



      As I see the problem with method Miscrosoft.Scripting.Utils.MathUtils.ToFloat64  how to fix it I don't know.... help please =(

    • tsiriaks
      Ansys Employee

      Hi Trouyan2 ,


      This error usually means that you have issue with IronPython. The easiest and quickest way to verify if this is the case here is to go to your D:Program FilesANSYSv191commonfilesIronPython , then double-click the 'ipy.exe' . Some similar error message should pop-up in the CMD Prompt.


      Now, the difficult part is to search on your systems and identify what or which software that has IronPython and is interfering with the IronPython shipped with ANSYS installation.


      Some possible causes that we've seen in the past including


      1. Check any environment variable related to IronPython (try unset it but please be aware that this might break something on your system that is using this environment variable)


      2. Check Global Assembly Cache (GAC) to see if there is any reference to another version of IronPython on your system. If you have Microsoft Visual Studio, you can open up the Developer Command Prompt with "run as administrator" , then issue the command


      gacutil /l IronPython


      This is to search for any reference of another IronPython version on the system, you can then use


      gacutil /u IronPython


      to remove it (but, again, be aware that this might break some software that installed this on your system)


      Thank you,


      Win

Viewing 16 reply threads
  • You must be logged in to reply to this topic.