Convergence issue

bhrigu_rishibhrigu_rishi Member Posts: 1

I was trying to replicate a paper (Bao et al., Solar Energy Materials and Solar Cells 168 (2017) 78–84) in Lumerical. Random media of TiO2 with volume fraction 0.4 and radius 0.5 micrometre. The structure span 4*4*10 micrometre. The reflection I am getting similar but the sum of R+T is not equal to 1. Since media is lossless so there is no chance of absorption. I tried different things such as changing the mesh size, changing the position of the source and monitor but there is no change in the result at all. I also tried to replicate some experimental work on TiO2 random media. But again R+T is not equal to 1 and R is giving lesser than whatever reported in the paper. I have attached the results obtained from the simulation and reported in the paper (Bao et al. 2017).

One thing which I want to mention

that when I did the simulation of similar random media for smaller thicknesses such as 1 or 2 micrometres then R+T is giving 1. But as thickness increases, T approaches zero.

Thanks.

Answers

  • shkimshkim Posts: 71Ansys Employee

    The wavelength range you are currently using is quite broad. This will generally require very fine mesh over a very large simulation region. You might need to check the following settings:

    • PML proximity: To avoid the evanescent field interfering with the PML, you need to set the distance from the PML to the structure to be larger than a quarter of the max wavelength. You need a convergence test to make sure the distance is large enough.
    • Broadband source: When injecting broadband, it is possible to inject a non-negligible field outside the wavelength range, making the simulation unstable and contributing to spurious results
    • Simulation time: Check if the simulation has terminated by reaching the auto-shutoff level.

    You might find the following posts useful:

    https://forum.ansys.com/discussion/24202/general-fdtd-troubleshooting-tips-and-tricks

    https://forum.ansys.com/discussion/24201/key-fdtd-simulation-settings

    Apart from this, simulating random structures requires further attention to the source and boundary settings. If you can share the screen capture of your simulation, I can make further comments.

  • bhrigu_rishibhrigu_rishi Posts: 7Member

    Thanks for your reply. I have kept sufficient distance from the structure to PML to avoid PML proximity. For the source, I used a plane wave source. I have attached the screenshots of the source and boundary settings. Others are the default conditions I have used. Please let me know if you need anything else.


  • bhrigu_rishibhrigu_rishi Posts: 7Member

    I also noticed a strange thing, I simulated a simple cube of thickness 10 micrometre and the autoshutoff level showed constant value (around 2.1*10^-4) after a certain simulation time and when maximum simulation time reached (figure attached), it showed FDTD status 1. However, the R+T was 1. In this random media simulation also, I increased simulation time but again after a certain simulation time it was showing a constant autoshutoff level till the maximum simulation time reached and thus FDTD status 1. But in the random media case, R+T was not 1. Why does autoshutoff value is not decreasing any further for thick samples? Are there some specific settings for thick samples (tens or hundreds of micrometre)?

    Please help.


  • bhrigu_rishibhrigu_rishi Posts: 7Member

    @shkim sir, could you please share your thoughts on how to simulate large random structures in FDTD? I tried different settings but not able to resolve this issue. And as I mentioned previously when structure thickness is low I am getting R+T=1 but as thickness increases, R+T is not equal to 1. So, maybe some extra precaution or some settings need to change for large random structures. Could you please let me know what are those settings? How to resolve this?

    Also, it would be very helpful if one can write all the necessary settings required to solve random structure in 3D as well as in 2D in a separate discussion page.

    Hope to hear from you soon.

    Thanks in advance.

  • shkimshkim Posts: 71Ansys Employee
    edited May 24

    Sorry, @bhrigu_rishi for my late response. There was some mistake with my notification setting and I didn't get notified of your previous post. The issue has been resolved and there won't be such a delay in my future responses.

    When you use periodic BCs, there can be multiple diffraction orders. Some of these orders can propagate at a very steep angle, resulting in poor absorption by PML. So, you might want to try "steep angle" profile instead of "standard." You can also try increasing the number of pml layers.

    I noticed that your wavelength range is very wide, which can contribute to slow convergence. Please try reducing the span of the wavelength and see if there is any improvement.

    There used to be some KX posts about the simulation settings for random structures. I will have a look and migrate relevant content, if any, to KB.

  • bhrigu_rishibhrigu_rishi Posts: 7Member

    No issue. Thanks for your reply.

    I already used "steep angle" but there aren't any changes in the result. The maximum number of PML layers used by me till now is 24. I will further increase it.

    I checked transmission values at different positions along with the thickness of the structure and it is giving almost zero which means all the incoming wave disappears after hitting the top surface of the structure. Some of them going back and giving reflection but the rest where are they going, don't know. And, this is only happening when I am increasing the thickness of the structure (greater than ~5 micro metre).

    One intuition is that whatever reflection, the simulation is giving is correct, the only problem is with the transmission value. But, don't know how to check this?

    Also, the maximum mesh size I used till now is 30 nm, and in some cases 10 nm only in the z direction. Should I go below further?

    Please send relevant KX posts about random structure if you find any.

    Thanks.

  • shkimshkim Posts: 71Ansys Employee
    edited May 25

    I suspect that as the layer becomes thicker it behaves as a waveguide in the lateral direction. Since you have periodic BCs in the lateral direction, the field that propagates laterally in the waveguide would take a very long time to dissipate through radiation.

    Appropriate mesh size can be determined through convergence tests. If the simulation result does not change, there is no need to further reduce the mesh.

  • bhrigu_rishibhrigu_rishi Posts: 7Member

    So should I use PML boundary conditions in lateral directions also? Or there is no feasible solution for such type of problems!!

    Thanks

  • shkimshkim Posts: 71Ansys Employee

    It should be noted that the slow convergence in the case of a thick layer with periodic BCs is physical and is not something that can be attributed to wrong simulation settings. The simulation is giving you what is expected from the given configuration. To circumvent the slow convergence, you can use PML BCs together with a Gaussian source. If you are using a Gaussian beam in your experiment, then using the same type of source in the simulation would make sense, unless the beam diameter is too big and, as a result, the required memory becomes too large.

    If you use PML in the x and y boundaries, you cannot use planewave since it will cause the source field to be truncated. When using the Gaussian source, you need to set the x and y spans of the FDTD object to be large enough to avoid the truncation of the source field.

    All in all, to obtain a simulation result that is comparable to a measurement result, your simulation settings should faithfully represent what is done in the experiment. If the issue is the amount of required memory, you would most certainly need to increase the available memory, rather than drastically simplifying the simulation settings or making too much of an approximation. Of course, there are cases where you can use some tricks to reduce the required memory by utilizing symmetries, downsampling data, and so on. But, in your case where a thick layer is used, there does not seem to be an easy workaround.

  • bhrigu_rishibhrigu_rishi Posts: 7Member

    Thanks for your suggestions. I will implement these suggestions and check whether they can help to resolve this issue.

Sign In or Register to comment.