About mesh multiplier in MODE

cqtaveecqtavee Member Posts: 5

Hi All

I am trying to simulate this example recently: Edge coupler – Lumerical Support

In the Script file of the no substrate case, (file name: Edge_Coupler_No_Substrate.lms) they are using codes to add taper structures. However, when they are adding the Si substrate override mesh, they used these two lines (line 158 and 159) of codes which cannot run on my computer.

set("set mesh multiplier",true);

set("z mesh multiplier",4);

May I ask what is the meaning of these two lines? Are they important for this program?


Many thanks in advance!

Tagged:

Best Answers

  • gsungsun Posts: 751Ansys Employee
    edited June 1 Accepted Answer

    Hi, This is a special feature for MODE product: it means thatthe override mesh size changes the multiplier times from the original mesh .When the "mesh multiplier" is larger than 1,the mesh is finer; when it is smaller than 1, it is coarser.

    set("set mesh multiplier",true); to enable this feature

    set("z mesh multiplier",4); to assign value

    I tested both R1.3 and R1.4 in FDE and both work. here is the test for the same file you mentioned:

    Please check the error message and make some modifications after some diagnoses.

    You can enable anther feature (by default) to directly assign the override mesh:


    The script is similar. Please try.

    Or you may need to update the version. or please tell us what is your computer OS version.

  • cqtaveecqtavee Posts: 12Member
    edited June 1 Accepted Answer

    I copied down the scripts and added the same SMF-28 fibre by codes. But I cannot get the same mode profile as the example project. I'm very sure I'm using the same parameters like the example. The first one is my result, and the second is the mode profile from the example file.

    My codes are attached. I was thinking the problem is from the mesh setting. But now it looks like meshes are correct.

    Very appreciate it if you could give some idea about finding where the problem comes from. I did not do much modification but just add fibre and fde simulation area.

  • gsungsun Posts: 751Ansys Employee
    Accepted Answer

    I am not sure what version and computer OS you are using. I tested it works fine:


    Similarly for FDE.


    I guess you are using varFDTD solver, which does not work.


    As for the mode issue, please write a separate post.

Answers

  • cqtaveecqtavee Posts: 12Member
    edited June 1

    Hi!

    Thank you so much! I noticed a wired thing:

    When I am running the script to add the mesh, the two checkboxes are called "set maximum mesh step" and "set equivalent index". That's where the error comes from. Because there is no checkbox called "set mesh multiplier".



    However, when I add the mesh manually, the two checkboxes are changed to "set maximum mesh step" and "set mesh multiplier" magically. And the window looks the same as the screenshot you showed.

    (I'm using R2.3 version)

Sign In or Register to comment.