How to prevent Fluent from remeshing boundary elements?

ansysuseransysuser USA Member Posts: 45

Hello, I am doing a series of simulations with high boundary deformation. To achieve the deformation of the boundary, I am assigning the coordinates of each boundary node at each time step. The problem is that since I have such high deformations I need to remesh the interior. This works fine until Fluent at a certain time step remeshes the boundary and adds a node. Since my UDF looks for the known boundary nodes to assign the new coordinate when the time step updates, the new node doesn't have anywhere to go and so it gives me a negative cell volume.


To avoid this, I thought to add an inflation layer to the boundary, thus adding a layer of quadrilaterals that would not remesh since they're not remeshed with a local Cell remesh setting. Unfortunately Fluent cannot keep up with the deformations on the interior enough to prevent the inflation layer from becoming so distorted that it too will give a negative self volume.


Is there a way to prevent Fluent from touching the boundary when remeshing the interior?

Tagged:

Comments

  • sdebsdeb Posts: 253Forum Coordinator

    Hello,

    Will it be possible to move the inflation region to a separate zone? You will have better control over the dynamic mesh settings in that case.

    Regards,

    SD

Sign In or Register to comment.